Can't find MQTT Action/1.X MQTT

I tried to read alot of topics before reaching here, I can’t find a solution.
I will detail below.
OS - RPI3 plus B Model
Openhab Version - 2.5.12 Stable version

I can’t find MQTT Action and MQTT 1.X Bindings.

  • In the settings I’ve allowed lagacey 1.x binding.
  • Also I’ve changed in the add.cfg from standart to expert, reboot few times and still not getting the 1.x binding.

Thank you all.

If you’re just starting out with MQTT I would recommend just using the V2 binding, which has the Action in-built.

The remote repository has changed.


I have read the topics you post here, If I got it right I need to download openhab-addons-2.5.12.kar that conatins those v1 add ons.
I’ve downloaded from here: Download openHAB | openHAB under section - Manual Installation.
Still can’t find those MQTT Action and MQTT v1 at bindings.

Nope, for v1 addons you also need the separate ‘legacy’ kar

Hi, a little edit, as I saw also in your Reply at the topic you mention, that I need that Lagecy Kar seperate, how should I call it ? I need to put it in Openhab-Addons with the original?

Yes, that’s what you do with .kars

But how should I call it, and how should I call the original?
Can you provide for me links?
Thank you.

Same as you install other bindings and Actions in OH2, use PaperUI or use addons.cfg

I have tried to search it it doesn’t show up but I show up.

You still need to “include lagacy v1 bindings” and disable “remote repository”

Hi sorry for late respond, I’ve didn’t have time to work on it this weeks, anyway I’ve “Include lagacy v1 binding” enable and Disabled Remote repository, yet, I can’t install v1 binding.
What did I do so far:

  1. Downloaded - openhab-addons-legacy-2.4.0.kar (Added to Addons files)
  2. Installed MQTT 2.4 Action + MQTT 1.X (In binding ,P.S, In binding I’ve installed MQTT 2.5 Binding)

Still I cant use ‘Publish’ method from mqtt action, even the fact is installed.

*Edit: I cant activate MQTT Broker , In Papaer UI > Services > I have configure MQTT Broker. (nothing in Inbox). Then tries manually add MQTT Broker Thing, but it’s “UNINITIALIZED” . what do I miss here?

I’m pretty sure these are incompatible at 2.5

I apprciat your help but if you can be more detailed and give information that you know.
What should I do?
How can I downgrade to 2.4?
How can I make 1.x lagecy work with 2.5 binding?

I don’t think you can unless you can find an install package for 2.4 so you can do it manually, I do not of anywhere openHAB still provides this. Maybe you’ve got a copy.

Maybe you can be more detailed.
What are you trying to acheive here?

I think you can run 1.x MQTT bindng and 2.5 MQTT binding alongside each other.
You must take care that they connect to your broker with different client ID, so they looklike different systems to the broker.

I do not think you can run 1.x MQTT Actions with 2.5 binding present (which gives you 2.5 Actions whether you use them or not).

So I can’t use the MQTT Action, because that is what I want.
I’m trying to run a MQTT github for Broadlink.
Anyway, There is no way I can use 1.X MQTT Action with 2.5 MQTT Binding?

You can install 1.x Action without 2.5 binding.
Or, why not use the 2.5 Action?

I don’t know, I don’t think so.