Can't find Xiaomi Smart Gateway v2

Hello everybody!

I’m just starting with OH, but I got a weird issue with Xiaomi binding already.

I bought Xiaomi Smart Gateway v2 (with light and radio ) and Magic Cube Controller. I followed instructions and was able to add those devices to my Mi Home account at the mobile app. It works fine.

I installed OH (2.2.0 #1061) and “Xiaomi Mi Smart Home Binding” (I’m using a laptop with Windows OS). I followed instructions and activated “local area network communication protocol” but I can’t discover the Xiaomi Gateway in openHAB.

I read all topics related to Gateway at this forum. I found some recommendations for reset gateway and performing all steps again - it didn’t help.

Gateway’s firmware version is 2.37

I’ll be grateful for advises or even link to the topic where this issue solved.

I had the same problem with win 7.
It was a problem with “multicast” when I enabled a VPN connection.
Also test turning off ALL firewalls on your computer (Domain, Private and Public).
Restart OH and try again :slight_smile:

1 Like

Hello, sintei!

It is very weird, but I turned off ALL firewalls, restarted OH, and (miracle!) OH found a Gateway! I turned all firewalls on. Reboot my laptop. Run OH and it was able to discover the Gateway again! I see no reason for it, but thank you for the hint!

1 Like

I had the same problem on a linux machine (ubuntu 16.04). See post: Xiaomi MiHome Gateway not responding (Solved)