Can't get FGSS001 z-wave smoke sensor working

I got a Fibaro FGSS001 smoke sensor that I can’t get working.
It’s reported as a FGSS101 in HABmin. Don’t know if that matters but it doesn’t work for me. Neither temperature nor tampering is working (It was working earlier with OH1. Also tried OH2 earlier and it worked then as well).

I get these warning/error messages.

2016-12-23 12:17:23.476 [WARN ] [tocol.commandclass.ZWaveCommandClass] - NODE 13: Unknown command class 0x91
2016-12-23 12:17:23.478 [ERROR] [ssage.ApplicationCommandMessageClass] - NODE 13: Unsupported zwave command class MANUFACTURER_PROPRIETARY (0x91)

Tried deleting the xml file for node13 but that didn’t change anything.
I read something about FGSS101 losing its channels but that was 20 days ago. I did a fresh (snapshot) install 8 days ago (and I did an apt-get just a few days ago) so I assume that it doesn’t affect me.


Number    FGSS001_1_temp          "FGSS001_1 - Temperature [%.1f C]"    <temperature>             (temp)                { channel="zwave:device:15912e68c95:node13:sensor_temperature" }
Number    FGSS001_1_batt          "FGSS001_1 - Battery Level [%d %%]"   <battery>                 (batt)                { channel="zwave:device:15912e68c95:node13:battery-level" }
Contact   FGSS001_1_alSmoke       "FGSS001_1 - Smoke Alarm [%s]"        <contact>                 (stat)                { channel="zwave:device:15912e68c95:node13:alarm_smoke" }
Contact   FGSS001_1_alTamp        "FGSS001_1 - Tamperig Alarm [%s]"     <contact>                 (stat)                { channel="zwave:device:15912e68c95:node13:alarm_general" }
Contact   FGSS001_1_alHeat        "FGSS001_1 - Heat Alarm [%s]"         <contact>                 (stat)                { channel="zwave:device:15912e68c95:node13:alarm_heat" }


Oddly, there are two entries in the database with the same Manuf, Type, and ID – FGSS101 and FGSS001. The FGSS001 db entry looks more complete than the FGSS101. However, it looks like discovery is picking up the FGSS101.

@chris Should the FGSS101 entry be deleted?

1 Like

Well spotted.

Quite possibly - I’m not sure if the FGSS101 really exists. If I do a search, plenty of hits come up with the FGSS001, but there’s no official ones for the 101, and links I do find link to the manual for the 001…

I’ll mark the 101 as deleted and update the database tonight.

Did an apt-get, deleted the thing and deleted the xml file. Did a re-start and then recreated the thing when it popped up in the inbox. Now it’s working. No more warning/error messages for this node.