Can't install influxdb + Grafana


I cant install influxdb + Grafana. I have tried many times with a completely newly installed openhabian. I have tried with Pi 4b and Pi 3b+ and I have even tried to downgrade it to 2.4 but the installation but I always get this message:

“Sadly there was a problem setting up the selected │
│ option. Please report this problem in the openHAB │
│ community forum or as a openHABian GitHub issue.”

And its stop at the same place:

BlockquoteProcessing triggers for dbus (1.12.16-1) …
Updating FireMotD available updates count …

$ systemctl daemon-reload

$ systemctl enable grafana-server.service
Failed to enable unit: Too many levels of symbolic links

$ systemctl start grafana-server.service
Resetting Grafana admin password…
$ grafana-cli admin reset-admin-password admin
/opt/openhabian/functions/helpers.bash: line 24: grafana-cli: command not found
FAILED Connection Grafana to InfluxDB…{“message”:"Invalid username or password "}Adding openHAB dashboard tile for Grafana… 2020-05-16_09:35:28_CEST [openHAB ian] Adding an openHAB dashboard tile for ‘grafana’… OK
Adding install InfluxDB with database configuration to openHAB
$ touch /etc/openhab2/services/influxdb.cfg

2020-05-16_09:36:39_CEST [openHABian] Updating Linux package information … 202

I have used influxdb +Grafana on openhab before but when I this week tried to restart the whole project I failed to install it.

Any suggestions? Can I do it manually with a older version but still setup nicely at openhab:3000?

Best regards


I’ve got the same situation - Pi3B+ and OpenHabian. I’ve tried to install FireMotD but there is an error while I’m doing this - the same situation like:

Can anyone help? Thank you in advance!

Thank you in advance!

looks like the service already was enabled before

Otherwise this would not result in OK

which version of grafana package is installed ?
A version that is being provided by the OS itself or the version that is installed by openhabian script?

I followed the steps described here to install influx + grafana as I am not using openhabian and I also had to use a different port than 3000.

This looks like you installed two grafana packages ( grafana-2.6.0+dfsg-3+b1 and grafana-data ) that are being provided by the OS. openhabian tries to install grafana-5.1.4 from the grafana repository.
I suggest to try to remove the OS packages before trying to run openhabian to install.
Openhabian added the grafana repository in /etc/apt/sources.list.d/ thus the manual installation also will try to overwrite the systems package.

which version of grafana package is installed ?
A version that is being provided by the OS itself or the version that is installed by openhabian script?

I have only tried using the auto install in openhabian-config. I have more than 5 times installed a clean openhabian then tried installing it but get the same error. On diffrent RPi and SD cards.


Neverthless I would be interested to see which version is installed. Could you check:

dpkg -l | grep grafana


[> 15:26:43] openhabian@openhab:~$ dpkg -l | grep grafana

ii grafana 2.6.0+dfsg-3+b1 arm hf feature rich metrics dashboard and graph editor
ii grafana-data 2.6.0+dfsg-3 all feature rich metrics dashboard and graph editor - data files

These are the two packages that belong to the OS. 2.6 version of the grafana package does not include the grafana_cli binary.
I would suggest to deinstall the two packages and try to run openhabian installation routine again.
In case that does not work I would do the manual installation. This runs on my installation.

1 Like

Operation Successful!

Thank you for the help!

Could someone explain how to resolve this in “simple terms” with some instructions?
I have tried a few times and it keeps failing…

You get the same error message that granfan-cli canot be found ?
What is the output of the command

sudo dpkg -l |grep granfana

After a failed install thru openhabian-config
then I did:

sudo apt-get remove grafana 2.6.0
sudo apt-get remove grafana-data 2.6.0

and then installed it again thru openhabian-config and it was successful. Done it twice on different devices…



Thanks for you reply! When I run this I get no output at all?

Thanks @dillunge running those 2 commands appears to have worked as I’m not getting the error anymore! Thanks :slight_smile:

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.