Can't login anymore

I run openhab on a raspi. About a year ago, I ran into problems. So I tried to install a backup. The result was that I couldn’t login anymore. I didn’t know what to do, was frustrated and didn’t have much time for OH anyway.
Now I’d like to get my system running again, but since I’m no expert and time has passed, I don’t really know what to do. I can’t login on the pi/linux-level using Putty when I enter the login-data from openhabian.conf: openhabian / userpw(my password).

Actually, I always get “access denied”. Even when there’s no SD-card in the raspi. So maybe the raspi is broken/doesn’t have access to the card?
Could you give me any tips on what to do, please?

IMHO this file is read only during initial setup, the password might have been change by you after that initial setup!


Where is the raspi running from if not from the SD card?

It’s a little embarrassing: I mixed up my openhab-raspi with another raspi. That explains why it doesn’t make a difference if there’s an sd-card or not.
But I can’t seem to find the openhab-raspi in my network. This is the closest I can find but using Putty with this IP just gives me a blank screen:

Looks like it doesn’t connect to my network or something is totally messed up. Do you have an idea what I could do/test before I have to setup everything from scratch again?

Try to login via keyboard and using a monitor.
If that does not work in case of a lost password you could mount the linux partition of the SD card to an other linux system and edit the file shadow which contains the encrypted password for the related account.