Can't open http://openhab link

Okay. Webface open up.

But, where is Initial Setup?

I think you don’t have to disable them. They are just hard-coded strings in the setup guide and everywhere. Using just the IP address of your openhab server will work everywhere and won’t cause problems (I’m sure because I use it that way everywhere…).
You should check your log why nothing shows up in the dashboard, maybe the install failed somewhere.

1 Like

How I can view logs?

There are several ways to do it.
Through SCP or simply SSH into your openhab server and view it there.
But please have a look at the documentation first, these must be included there.

Look:

Okay, thanx guys.

What next?

I don’t use openHABian, so I don’t know.

There are three other topics here:


.

Maybe there are some hints for you…

So, I think, openHAB is totally broken.

Where I can get working version of openHAB?

Yep, it’s broken.

QIP Shot - Screen 271

No it ain’t broken, it’s just not designed to work in a broken environment like yours.
You certainly have read about the prerequisites, haven’t you ?
Check the debug guide. Follow the guide, maybe the helps you get it to work, but don’t expect us to tell you how. Your setup is just too off-mainstream.

PS: and it is openHABian.

Clean Official Ubuntu Server 16.04 LTS is off-mainstream?

I do everything in steps in the official instructions published here https://www.openhab.org/docs/installation/openhabian.html#other-linux-systems-add-openhabian-just-like-any-other-software

I’m trying to get it to work, but the openhabian is not working. And I do not know why.

By some miracle I guessed that I needed to install Java. I tried to find the Zulu package - but it simply does not exist. At least Google doesn’t know where to find it. So, I’m installed some another java. I’m not specialist in Java, so I installed what is in the Ubuntu packages.

Next, I’m trying to install Grafana, InfluxDB, MQTT from openhabian-config, but I only get errors or failure messages.

I asked for help, because the openhabian is so complex and incomprehensible that it is impossible for a simple devop (me) to install it correctly according to the instructions from the 15th attempt in 7 days.

In general, I always tried to figure it out myself, but in this case this is basically impossible.

So I just ask for help in launching this “spacecraft flight control system” openhabian.

Perhaps there is some detailed working instruction, where it is written - in what sequence and what to install (for example, where to get Zulu, at what stage to install, how and when to install Grafana, InfluxDB, etc.) ?

Your DNS stuff is off-mainstream for sure and heaven knows what else.
And you have to meet the prerequisites. Read the README and debug guide as I told you to.
Strictly speaking, Ubuntu also is not supported although in general it works fine to install there.
But stuff like DNS resolving and unfiltered Inet access is a must.
As I said go read the debug guide set e.g. debugmode=maximum in /etc/openhabian.conf then you’ll see every command, it’s all just scripts, maybe that helps you, but don’t expect support for an unsupported system.

I am using arbian based on Ubuntu 16.04 LTS so far it is working.

I would do one step after an other.
The source for openhabian-config is available on github. As you execute it you already have it on your system. Take the first error message that you get and search in the code for the error message. A few lines above there must be a statement that checks for an error code or any other condition. This should indicate the item that needs to be fixed.
As already mentioned there is a guidline for how to debug the stuff ( haven’t done that as I like to have a look to the source code ).

As there are different versions of java be careful just taking one version.
I did not check all the details but as far as I can see also java can be installed by using openhabian-config. In the installation does not work you can have a look into the source to check where it’s taken from.

I am using the Grafana, InfluxDB package that is provided by Ubuntu 16.04. This is not the latest, greatest version as you would get by using openhabian-config. E.g. for Debian stretch based system this is or at least was a problem as the latest version use newer glibc versions. This will also happen vor 16.04 once the development is being done with a higher glibc version which will come as 20.04 is available.

Zulu ( java in general ) is a prerequisite; openhab can’t be started without java.
So that’s required before openhab to be started ( installed ).
Grafana, InfluxDB are optional. You need them to get persistence. Start first getting a running system; then add other optional stuff.

That’s how I understand how it works and how I would solve the problems. Of course there are other ways.

Your DNS stuff is off-mainstream for sure and heaven knows what else.

So, I’m try using 8.8.8.8 for next setup.

I go around all the restrictions within the country through dozens of VPNs working within BGP announcements, so the Internet has no restrictions.

Okay, guys. Thanx you all.

Now I’m start with Ubuntu 20.04 LTS.

So, I’m installing Ubuntu 20.04 LTS.
Next - I’m trying to install Azul Java (Zulu-8).
And than I’m ask you all - what I’m must do next…

After installing Java, follow the docs for packet installation of openHAB on linux…

Oh guys, I can’t install Ubuntu 20.04 because is only 64 bit.

But I need 32 bit. What I can do next?

Ubuntu page shows 32bit version as well

32bit for RPi…
But I prepared for this task Hewlett-Packard HP t5740e.

This computer has only 2 gigabytes of memory on board and 32-bit software will work with memory much more economically.

You are confusing me now.
Your first post said installing on a raspberry Pi, now you want to use a different machine ?
You should be able to find a 32bit version on Ubuntu pages as well.

Yes indeed.

First, I installed openHAB2 on HP (Ubuntu 16.04.6) and I started having the above problems. I thought - probably on Ubuntu normally will not work.

I took one of my RPi3, and installed openHABian with “openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img” on it - but it had exactly the same problems.

Nothing worked, although I put the official supported image on the officially supported hardware. I realized that the software out of the box does not work anywhere.

I thought that since the problems are the same on HP with Ubuntu and on RPi3 with official image, then I can trying solve these problems on HP, because I need RPi3 for other tasks…

It works fine with almost anyone. The problem isn’t in the software but in your environment hence changing boxes will not help either.
Take care to match the prerequisites and use debugmode=maximum as I told you.