Can't open UI (localhost:8080) after installation on Win 10 - "400 Bad Request"

  • Platform information:

    • Hardware: CPUArchitecture/RAM/storage
    • OS: Win 10 Home 64 bit
    • Java Runtime Environment: java sdk version “1.8.0_151”
    • openHAB version: 2.2.0 Release build
  • Issue of the topic:

Hi all, its my first try to run openHAB 2.

1: I installed java
2: I set system variable JAVA_HOME to C:\Program Files\Java\jdk1.8.0_151
3: I downloaded openHAB 2 and extracted it to C:\openHAB
4: I started the file start.bat (tried with double click in explorer as well as from command line)
Everything seems ok. No ErrorMessages.
(Following the output …)
Launching the openHAB runtime …
Release Build
Hit ’ …
and '[cmd] …
Hit ’ …


If I enter http://localhost:8080/ in the browser (testet with chrome and firefox), I get the message 400 Bad Request.

I cleard the browser cache and also tried to deactivate McAffe Firewall, but I always get 400 Bad Request.

Can you help me? What is going wrong?

THX, Marco

same here. Would be interested how to solve…


in that console window, what is the output of log:tail?

Is there anything else using port 8080?

1 Like

I dont know what happend in detail, but some minutes after writing the post I started an windows update.
Now the update is compleated and with the first try everything is working.

Hope you can solve your problem, Daniel.

THX for your fast answers,

1 Like

good to hear Marco!

after updating to 2.2 on my Rasperrypi, local host:8080 does not work anymore. ping on the ip is working.
any ideas ?

thanks alot

problem solved by myself :wink: Logged in/out and in again to my rasperrypi, after that It worked. Do not know eather but anyway its solved :wink: big smile! My openHAB 2.2 is running!!

1 Like