Can't pair Hue Hub

Just installed the latest oh2. Trying to pair a new hue hub. Not working. Not seeing the log messages instructing me to press the button on the hub. The page for the oh2 version of this binding doesn’t mention the log messages. Is that still how it’s supposed to work?

UPDATE: tried it a few more times and got the username created, but OH is insisting that the username has not been set in the configuraiton and is forcing the hub’s think offline. I can clearly see the username in the config:

openhab> smarthome:things show hue:bridge:001788a91ea0 UID: hue:bridge:001788a91ea0 Type: hue:bridge Label: Philips hue ( Status: OFFLINE (CONFIGURATION_ERROR): Cannot connect to hue bridge. User name for authentication not available in configuration.

vendor : Philips
serialNumber : 001788a91ea0

Configuration parameters:
ipAddress :
pollingInterval : 10
sensorPollingInterval : 500
userName : Qodb0MOj3Fya7IpLR1NR0RAgKQi7Ym6WknuyGobP

No channels

but in the log I’m seeing this over and over again:

2018-12-18 02:35:32.759 [WARN ] [ue.internal.handler.HueBridgeHandler] - User name for Hue bridge authentication not available in configuration. Setting ThingStatus to offline.

Will continue to troubleshoot, but if anyone else has seen and fixed this, I’d love to know how you did it.

UPDATE 2: This just started working. I’ve done some fiddling in the karaf console and a few reboots. Not sure what thing fixed it. Maybe the second reboot?

i’m having a similar issue and same messages except I can’t event get to get it creating the username. Any tips on how to get the user name created?


Downloaded and ran OH 2.5 Snapshot build - HUE detection worked perfectly and registered once Binding button pushed.
Captured Username from log file and entered this into OH2.4 setup everything now working as expected

Hi Kevin,

Sorry to reply so late. I never had issues with the username. I was able to see that in the log, but couldn’t seem to get the binding to use it. I read in another thread the idea of sniffing the traffic between the Hue app and the hub (e.g. with tcpdump) and lifting the password it uses, which is in the URLs of the api calls. I also switched to the latest snapshot and re-discovered once since then, and it seemed to work as intended.