"can't save sitemap" "can't save page" OH3

Hi there

just noticed a (new) error in OH3 which is pretty breaking for me currently, hope someone can help.

When I try to save any changes in any page/sitemap, I get the error “Error while saving sitemap: Server Error” (same thing when trying to save a page).

I tried restarting openhab, I tried emptying the cache, I even tried reinstalling (with apt-get --reinstall), tried restarting the machine, nothing changed.
I even copied the configuration (i.e. userdata and conf) over to a new machine and still get the same error, so it must be something with OH3, not with the OS.

There is no error in openhab.log - of course there might be a way to show the error, but for this I would need to know which component I would need to set to a different log level.

Can anyone help?

It might be that someone would see this as a permission error, but the thing is: I can save pages and sitemaps once after startup of OH3 - the error only appears after this.

Maybe also relevant:
My events.log and audit.log stay empty, i.e. they are created but stay at 0 byte.

Anyone any idea where I could look?


Hi @Pezzi42 ,

I have the same error. Did you find any solution yet?


Yes, I did.
It was an old sitemap which somehow was blocking this. I’m not entirely sure about the exact steps, but enable debug logging for the OpenHAB core, then try again - that should produce the name of the blocking file. Delete that file and you should be set.

Really weird.

I did:

openhab-cli console
log:set DEBUG org.openhab.core

and after that everything works.

Afterwards I reverted it to INFO and now everything works …

Thanks for the hint :wink: