Cant start openhab2 after update (solved)

Hello all!

I am using openhabian:

openHABianPi - 7.05.170509
Ip =
Release = Raspbian GNU/Linux 8 (jessie)
Kernel = Linux 4.9.35-v7+
Platform = Raspberry Pi 3 Model B Rev 1.2
Uptime = 0 day(s). 0:0:20
Updates = 0 apt-get updates available.
Processes = 128 running processes of 32768 maximum processes    

              openHAB 2.2.0-1 (Release Build)

I am using openhab2 on my Raspberry Pi 3.
After an upgrade to the latest v2.3.0 snapshot the system doesn’t start properly.
I’ve tried

[20:29:06] openhabian@openHABianPi:~$ sudo openhab-cli start --debug
A systemd service configuration exists...
Use 'sudo /bin/systemctl start openhab2.service' to start an openHAB service
Launching an instance in this terminal..
Launching the openHAB runtime...
Listening for transport dt_socket at address: 5005

And after this nothing happens…
I already tried to downgrade my system (back to 2.2.0-1 which you can see at the top information) and restored the /var/lib/openhab2/ directory via amanda backup (state yesterday).

Greetings from Germany

After 2 hours i’ve resolved the problem!
Step 1: Redo the upgrade to the latest snapshot (because downgrade was never a good idea)
Step 2: Clear Content from /var/lib/openhab2/cache/ and/var/lib/openhab2/tmp/
(as mentioned in Openhab 2.2 problem after upgrade)

1 Like