Can't use Homematic IP HMIP-WRC2

Hi all,

new year, new smart home. I now use openhab2.5 on an pi4 with homematic binding. Thermostat control works great. But I have an Wallswitch HMIT-WRC2 witch i can’t get to work.

I can config the items and see those in PaperUI. But when I push the buttons (PRESS_LONG and PRESS_SHORT) I dont receive the item update in the log files.

Know someone this problem?

Thanks Nils

Your set-up please

I think the “how to ask a question” thread needs to be updated to add

"We do not play guessing games. Provide, at a minimum the following information.
Hardware
OS
Java Version
OH version
Details on afftected hardware
relevant configuration
relevant logs
what have you tried in an attempt to resolve the issue?

We help you understand your system. We are not a configuration provider, providing canned configurations. We help you get your attempts operational."

Sorry i was in a hurry.

I usw openhabian 2.5 on a RPi4. Homematic Bridge is an Charly build with a RPi3b. Java should be version 8.

As I mentioned I try to use an Homematic IP Switch HMIP-WRC2.

Here are my items:
`//Wandtaster 2fach - PRESS_SHORT
Switch WandtasterKueche_oben_short “Wandtaster Kueche oberer Schalter - kurz” {channel=“homematic:HMIP-WRC2:97aed069:000193C99D48D2:1#PRESS_SHORT”}
Switch WandtasterKueche_unten_short “Wandtaster Kueche unterer Schlater - kurz” {channel=“homematic:HMIP-WRC2:97aed069:000193C99D48D2:2#PRESS_SHORT”}

//Wandtaster 2fach - PRESS_SHORT
Switch WandtasterKueche_oben_long “Wandtaster Kueche oberer Schalter - lang” {channel=“homematic:HMIP-WRC2:97aed069:000193C99D48D2:1#PRESS_LONG”}
Switch WandtasterKueche_unten_long “Wandtaster Kueche unterer Schlater - lang” {channel=“homematic:HMIP-WRC2:97aed069:000193C99D48D2:2#PRESS_LONG”}`

Openhab seems to not register a change of the state. There is nothing in the logs.

Do I need to give more informations?
(Sorry for the formatation. I write this on my phone)

1 Like

Hi all,

I can confirm the Problem. Yesterday I updated from openHAB 2.4 to 2.5 and HMIP-WRC2 stopped working. Nothing else changed and therefore I am very sure something broke during the update 2.4 → 2.5.

My System is openHAB 2.5 on Synology; Homematic on CCU3

Homeatic.things

Bridge homematic:bridge:bridgeID [ gatewayAddress="xxx.xxx.xxx.xxx" ] {
	Thing 	HMIP-WRC2 	thingID	"theName"
}

The HMIP-WRC2 is not linked to an item as I used it in a rule as
Rule

when
	Channel 'homematic:HMIP-WRC2:bridgeID:thingID:2#BUTTON' triggered LONG_PRESSED
then
[...]

The log file just shows that the thing is created, but nothing is triggered when a button is pressed on level INFO. I switched to level DEBUG and got:

Log

[DEBUG] [communicator.AbstractHomematicGateway] - Received new (Boolean) value 'false' for 'thingID:0#CONFIG_PENDING' from gateway with id 'bridgeID'
[DEBUG] [communicator.AbstractHomematicGateway] - Received new (Integer) value '-70' for 'thingID:0#RSSI_DEVICE' from gateway with id 'bridgeID'
[DEBUG] [communicator.AbstractHomematicGateway] - Received new (Boolean) value 'false' for 'thingID:0#LOW_BAT' from gateway with id 'bridgeID'
[DEBUG] [communicator.AbstractHomematicGateway] - Received new (Boolean) value 'false' for 'thingID:0#UNREACH' from gateway with id 'bridgeID'
[DEBUG] [communicator.AbstractHomematicGateway] - Received new (Boolean) value 'true' for 'thingID:2#PRESS_SHORT' from gateway with id 'bridgeID'
[DEBUG] [mematic.internal.misc.DelayedExecuter] - Delaying event for 2.0 seconds: 'thingID:2#PRESS_SHORT'
[DEBUG] [communicator.AbstractHomematicGateway] - Received new (String) value 'bridgeID' for 'CENTRAL:0#PONG' from gateway with id 'bridgeID'
[DEBUG] [mematic.internal.misc.DelayedExecuter] - Executing delayed event for 'thingID:2#PRESS_SHORT'

I tried to link to an item. Linking worked, but nothing is triggered.

I even tried to update the CCU3 but this made no difference.

Best regards
Peter

???
Now it started working.
I am not aware what I changed, but as soon as I know it, I will report.

I use the switch in combination with the HmIP-FSM. I have the HmIP-FSM in Alexa over openhab and it works. But I dont See anything in the logs for this one to. So i try to configure a rule for the switch and see If it will Work.

Hey there,
I have tested some rules with the Switch as Item and nothing works. I have also an HmIP-BSM in the livingroom with the same - let me call it - error.

What I discovered is that when openhab and/or the RaspberryMatic starts the switches changed from NULL to OFF.
2020-01-07 11:05:24.369 [vent.ItemStateChangedEvent] - UnterputzWZ_unten_long changed from NULL to OFF

But every button press is not logged from openhab.

The next step is to try the rule with an channel trigger.

I found a solution. You have to set programs in the CCU for triggers. The programs can be totally senseless, but have to resume the button you want to transmit to openhab. Without the programmes the trigger won’t work in openhab.

3 Likes

Hello, it looks facing exactly the same issue with HmIP-WRCC2. As not been experienced in using the CCU so far, can you share an example senseless programm making the channel usable in Openhab?.

this is unbelievable, after adding this in the ccu rules or programm my itmes worked immediately.

Thsi can’t be a feature - anyhow you made my day!

1 Like

I can confirm the same!
Another happy user :smiley:
@Christian_Hartmann nice find!

1 Like

@NilsAcht could you please set the solution on my post

Unfortunately this didn’t solve the Problem for me. After I added the rules a could at least see the correct button triggers in the CCU protocoll.

But the trigger doesn’t seem to get sent to the OH Interface.