Challenges with Manual .thing configuration settings vs. Just using Paper UI

New to openhab2 learning a lot. My main challenge is trying to understand how to identify all of the .thing parameters for a thing go to ONLINE status.

For example, I have a GE In-Wall Dimmer Switch GE 14294 (ZW3005).

Using the Paper UI to configure the thing it quickly comes online. If I remove that and try to manually configure the same device in a .thing file it never comes online. Here is an example of my manually configured .thing file:

Thing zwave:device:790532be:node2 “Bar Dimmer Switch” @ “Bar” [ config_3_1=“0”, config_4_1=“0”, config_5_1=“0”, config_7_1=“3”, config_8_2=“3”, config_9_1=“3”, config_10_2=“3”, config_11_1=“1”, config_12_2=“1”, switchall_mode=“0”, config_1=“node1”, config_2=“node1”, config_3=“node1” ]

This reference provides a list of the parameters for this device:

However it seems to be missing a few additional values that the Paper UI thing configuration has which are: lifeline, basic group, scene group which I believe to be config_1, config_2, and config_3 (based on trying to logically match the parameter naming convention/pattern).

Looking at the Paper UI thing configuration sections there are:
Configuration Parameters (Which are the official params in the reference guide)
Association Groups (Referred to in the reference guide but missing actual param names)
Device Configuration (Polling Period/Command Poll Period, can’t find these references in the guide)

So long story short I’m having a hard time trying to identify ALL of the thing parameters for each device. It seems that without defining them ALL the thing will not go online. Using Paper UI it seamlessly fills in all the defaults and away it goes, works just fine. I’ve compared all of the settings from the Paper UI configured thing against the documentation and they are all setup properly. However with the missing params I am assuming that’s the reason why my manually configured device won’t come online just sits in = Status: UNINITIALIZED - HANDLER_CONFIGURATION_PENDING

Any insights/tips are greatly appreciated.

You are missing the Bridge and your Things config is wrong:

Thanks. Sorry, not sure what a bridge is, I couldn’t find that in the documentation. Did you mean binding? If so yes I already have zwave binding installed and its working find.

Yeah I’ve used this article already which is how I came up with the formatting:

Thing <binding_id>:<type_id>:<thing_id> "Label" @ "Location" [ <parameters> ]

I’ve also defined my Z-Wave Controller using this method and it works just fine:

Thing zwave:serial_zstick:790532be "Z-Wave Controller" @ "Datacenter" [ port="/dev/ttyACM0", controller_softreset="false", controller_master="true", heal_enable="true", security_networkkey="<key_goes_here>" ]

I think my main problem is that there are certain parameters I am missing. As per this document: further reading seems to show there are 5 additional MUST HAVE parameters for zwave devices being: zwave_nodeid, zwave_manufacturer, zwave_deviceid, zwave_devicetype, zwave_version however those don’t seem to be the actual parameter names. I keep trying different formats like nodeid or node_id instead of zwave_nodeid and none of those seem to be working. At least the in the GE switch guide it was clear exactly what the parameters were vs generalized textual references to them.

Bridge zwave:serial_zstick:controller "ZWave Controller" [ port="/dev/tty.usbmodem1421", controller_softreset="false", controller_master="true", heal_enable="true", security_networkkey="11 22 33 44 55 66 77 88 99 AA BB CC DD EE FF 00" ]

Thanks, strange I have mine configured as a Thing not a Bridge and it seems to be working:

Thing zwave:serial_zstick:790532be "Z-Wave Controller" @ "Datacenter" [ port="/dev/ttyACM0", controller_softreset="false", controller_master="true", heal_enable="true", security_networkkey="<key_goes_here>" ]