Changes in thing config files not populated in OH4

I made some major changes around the icloud binding for OH3. No after the upgrade to OH4 I ran into a problem regarding files based thing configuration.
The binding uses a bridge thing with username, password and a 2-FA id.
The authentication logic requires changes to the thing file while OH is running. This worked perfectly with OH3. After the change the .thing file was read and the thing was re-initalized.
With OH4 if I change the config parameters for the thing, the thing file is re-read but then nothing happens.
If I disable and re-enable the thing it is reinitialized but with the old config files, not those from the change .thing file.
Is that the intended behaviour? In my opinion the OH3 made much more sense…

Are you using FIrefox? Many users have been seeing issues recently with Firefox caching parts of the javascript environment of the UI, this sounds like it could be similar.

I see the outdated values in the debugger. So I assume the problem is not browser related

Which specific version of OH are you on? I noticed this today with the Denon Marantz binding. I changed my IP address on the receiver and I ended up having to restart OH to get it to apply.

I saw something similar, but I thought it was related to the binding, so I reported it in the Issue below.

I’m using 4.0.2

PS it is most probably NOT a browser cache issue, since I see the config param value not changing on diffetent devices and browser instances.

Do you have things from different bindings in the same file?

I’m seeing a pretty similar issue, with all things used in the file being from a single binding.
I don’t think that’s the right direction to look after.

My denon is a single line in a file all by itself. No other bindings. The only configuration option it has is the ip address of the device. I restarted the thing on the gui and it had no effect. Only a restart of OH fixed it.

That said, I did see an odd error message on that reload now that I go look at the logs.

2023-08-30 17:36:36.457 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed to refresh bundles after processing config update
org.apache.karaf.features.internal.util.MultiException: Error:
	Error downloading mvn:io.swagger.core.v3/swagger-core/2.2.15
	Error downloading mvn:io.swagger.core.v3/swagger-annotations/2.2.15
	Error downloading mvn:io.swagger.core.v3/swagger-integration/2.2.15
	Error downloading mvn:org.javassist/javassist/3.29.2-GA
	Error downloading mvn:io.swagger.core.v3/swagger-models/2.2.15
	Error downloading mvn:io.swagger.core.v3/swagger-jaxrs2/2.2.15
	at$MavenDownloader.<init>( ~[?:?]
	at ~[?:?]
	at org.apache.karaf.features.internal.region.Subsystem.downloadBundles( ~[?:?]
	at org.apache.karaf.features.internal.region.Subsystem.downloadBundles( ~[?:?]
	at org.apache.karaf.features.internal.region.SubsystemResolver.resolve( ~[?:?]
	at org.apache.karaf.features.internal.service.Deployer.deploy( ~[?:?]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision( ~[?:?]
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13( ~[?:?]
	at ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker( ~[?:?]
	at java.util.concurrent.ThreadPoolExecutor$ ~[?:?]
	at ~[?:?]
1 Like

There’s now a 4.0.3 release that fixes some file reloading issues:

@wborn is there a particular snapshot that includes all the patches? I’m on one from earlier this week and still have this issue. It’s intermittent for me. I could restart 10 times and 5 times it happens and 5 times it doesnt. Ive also noticed that when the things load they dont necessarily load at the same point. Some times its before items and rules, sometimes between, sometimes after both.

Last SNAPSHOT, built after the patch release, should give you what you want.

I’ll update tonight or tomorrow and retest. Im on 3615 from 04SEP, 3624 is the most current at the moment.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.