Character-Set Problems

  • Platform information:
    • Hardware: X64 PC
    • OS: WIN 10
    • Java Runtime Environment: Oracle JDK 1.8.0_231
    • openHAB version: 2.5.0M6
  • Issue of the topic: Character-Set Problems
  • After Updating from 2.5.0M1 to M6 special characters ar not presented well
    It worked fine in V2.4 and V2.5.0M1
    e.g.: AVM Fritzbox BindingTemperature: 22.0 �C


this in paper-ui as well as in Habpanel.

1 Like

Try clearing your browser cache?

Clearing Browser cache changed nothing ( in 3 different browsers)
Are there any other suggestions?

Have you made a change of your .items-file ? Is it still of file-type “UTF8” ?


There must be another reason.
This is a discoverd item from AVM-fritzbox binding without manual editing - added via Paper-UI.
It comes not from an items-file.

Mine looks:

Maybe there is something wrong with your language-settings ? You can try this:

[11:35:18] openhabian@openHABPi:~$ env | grep -i lang
[12:15:28] openhabian@openHABPi:~$
1 Like

Sorry, as written in the start-post - this is a WINDOWS 10 installation not a raspberry!

In V2.5.0M1 it was ok like yours. So i mention that ther is thomething different in M1 vs. M5/M6.

But your Java install on Windows still has language environment settings, which you can check using env in a karaf console.

1 Like

ENV is ident on languagerelated items.

Different are the ports and directorys due to the same instance.

Now i dedected difference in displaying special characters when openHAB2 is startet on commandline versus started as windows-service:oh2_direkt
oh2_cmd Starting vom commandline displays well - windows-service does not. OH2.5 latest stable version.

I solved this problem adding this line:“UTF-8”

in the ‘openHAB2-wrapper.conf’ file

1 Like