CIFS Connection not working after update

network
networkshare
cifs
Tags: #<Tag:0x00007f51e097d608> #<Tag:0x00007f51e097d400> #<Tag:0x00007f51e097d248>

(Matthias Marx) #1

Hi,

I updated today from OH 2.4 Milestone to the latest official build. Right now I am unable t9 mount my CIFS share from my Windows device.

Normally it worked with „sudo mount -t cifs -o user=administrator //192.168.0.200/share /etc/openhab2/html“

I tried several mounting points and parameters but I still get the error message: mount error(2): no such file or directory

I also tried other shares without success. The mentioned share is accesible from other network devices.

Do you have an idea about this?

Thanks


(Rich Koshak) #2

Did anything else get updated at this same time? Because OH has nothing to do with the SAMBA configuration. openHABian sets up a share to mount folder from the RPi to Windows. But it looks like you are trying to mount folders shared by Windows to the RPi which is definitely going to be outside the scope of what OH or openHABian has control over.


(Matthias Marx) #3

Thanks for your answer. Nothing changed on the configuration of my Windows device. I am still able to connect to these shares from another Windows machine and also via App from my iOS device. So this share and other shares are definitively accessible with this user.
Are there more logs regarding this connection to check what the problem is?


(Rich Koshak) #4

There are probably samba logs somewhere. But really, this is all outside the scope of OH and openHABian so you probably will not find a whole lot of help on this forum. You might find more on a generic RPi forum or samba forum or the like.


(anonymous.one) #5

You may not of changed the share itself, but Windows updates may of change security of Windows File sharing in general. I run into issues when the SMB protocol is no longer set to NT1.0 (based on how I read your mount command); while this may not be the exact problem, you may want to research mounting Windows shares via SMB2 or SMB3.


(Matthias Marx) #6

Ok thanks. I already tried several SMB versions but also no success!

Thanks