ClassicUI - Icon changed - IOS App does not update (even after Cache cleaning)

Hi, i guess (my last thought) i have an IOS app issue. I changed in classic UI several icons but not all are updated in IOS app, web gui works fine, android app works fine…i tried several times to clear image cache in IOS app - but it simply does not change anything. Only way i did not try yet, to remove the app and reinstall.

Anyone an idea what i could try or having similar issues?
Maybe i need to use icon-setting differently in item definition?

Thanks a lot Norbert

1 Like

I believe the iOS App uses the Basic UI, not the Classic UI. Changes would need to be in your sitemaps.

not sure what you mean. I normally set icons in items file.
you mean that this is irelevant for classicUI and needs to be set in sitemap (?)

But how could it be that part of the items are shown correctly after the change of these icons, and a few are simply not accepted to change in IOS, android + webGUI work.

I do not use the Classic UI but I know the Basic UI shows nothing without a sitemap and mu iOS App references the same sitemap as the Basic UI.
Perhaps somebody more knowledgeable than I can assist.

Basic UI, Classic UI and the iOS app (as well as the Android app) all use the same .sitemap files.
(I have no knowledge about the iOS app, so I cannot help with that problem.)

1 Like

OK, I thought Classic UI was from OH1 and I assumed it might be different.

I find it is better to set icons in the items file, this way if it is used in multiples places in my sitemap they all have the icon and I don’t have to type it multiple times. It can be done in both files but the sitemap overrides the item file if u do both.

I am using the beta iOS app and icons are working fine, if u want to use the beta ask on the github to be invited for TestFlight. Beta works great with no issues here.


Just checked the non beta and they are working so you will need to post how you are using the icons and be sure to use code fences.

actually there is no limit in the participation in the beta on TestFlight: Have a look at

1 Like

its very strange…some of the icons i changed are shown correctly - and some others not.
As strange as it is, i use the same icon for various items, some are shown correctly some not - but i did not change anything at all - or do it differently. Already tried a <"…"> but it does not change anything.

On top - most funny i have a switch item…if i send the OFF i see the new icon, if i send the ON i see the old icon - but only a single file is in the icons folder…the new one.

and again, within the GUI all is fine and up to the state i expected to the to configs and files in the icons folder…

Sounds like you may be using custom icons? Make very sure you do not duplicate any of the filename families used in the standard icon set.

Example, you would never get camera-on.svg and camera-off.svg to work … because the default set contains a camera.svg that will be found first.

It’s probably time to show us examples of what you are doing.

Thanks, at least i would not know - i’m pretty sure as i know the standard icon set by OPENHAB and often cross check with the website where they are all presented.

I now fixed it - guess how - removed the APP and installed again. no clue why and how this was possible as i did many times before CLEAR icon cache.

Thanks Regards Norbert