Closed: Access disk file from iCalendar binding

I’m trying to migrate to openHAB, so I’m really new to some concepts of it.
I’m struggling to get a bridge item online that is referring to file:// URI instead of a http;// URI. Is that even possible.

Thanks for any hints,

I haven’t tried this myself but if that would be an option for you, you could place the file in the integrated web server folder under your config folder: conf/html

You should then be able to access the file via http(s)://openhabhost/calendarfile

Thanks a lot. It’s worth trying anyway. So I know it’s a protocol issue.

Might be a permissions issue. Your openhab.log might tell you.

Thanks rossko57,
I think you are right. I checked the logs before, but it tells me not much.

2021-05-04 15:46:02.829 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model ‘calendar.things’
2021-05-04 15:46:02.845 [WARN ] [g.icalendar.internal.handler.PullJob] - Download of calendar failed.

And it is in both cases the some error. Meaning with local disk access and local http:// request.

Can anyone confirm this URI working, please (for openhab v3). I’m still fiddling with this issue.
I can request the *.ics file manually from http://localhost:8080/static/ but not via a bridge definition. (neither with thefile:// URI)

getting annoying

I just tried the http way and got the same results (can download the file in browser but the binding fails to download).

However I cannot really replicate this to 100% since my server is only reachable via https. So this might in my case as well be a certificate error. I think you should try to increase the log level (I always forget how to do this so you would need to search the forums…)

Regarding the file type url: You’re not running openHAB in a docker container right? Just to make sure that your container can access the file if it is placed on the host machine.

have a look at the source code of the binding on if it supports file://.
I tried to have a look yesterday. I think file:// is not supported but cannot say for sure

Many thanks to all of you who took the time to think about my issue.
I just came back to explain why I closed the thread without posting the solution. Sorry for that.
I didn’t find one. Same as for many other basic issues from very start. Some of them discussed in other threads, some not.
My intended application seem to odd.
So the solution is to stick with FHEM. No offense!

Cheers, Chris