CLOSED: Tankerkoenig remains in Status 'unknown'

Hi everyone,

I have an issue with the Tankerkoenig binding on openHAB 3.3.0.M2.
I added two things. one for the bridge and one for a gas station. But unfortunately both remain in status ‘unknown’:

The bridge looks the following:

and the gas station:

I havde already tried by removing the binding and setting it up again but also without success.

Many thanks!

Did you already wati one full polling period (60 mins in your configuration)?

I am not sure how the binding handles its state but could be possible that the change to online, when a successful response has been made to the api.

Any output in the openhab.log / events.log file that helps to track down towards the root cause ?

The polling should start immidiatly after creating the things (no waiting until endof period). A change in the polling time should trigger that as well immidiatly.
I haven’t ever noticed both (bridge and station) remaing unknown (hence no failure description in the docs).
Please set the log-level to DEBUG, create another station and post the related log-entries.

Additionally please post or PM to me the used StationID as copied from MainUI.

1 Like

I tried to create a new Station using a WRONG StationID. That leaves this Station-Thing UNKNOWN. IMHO the bridge would remain UNKNOWN as well if it would have been only this one faulty station.
Please check your used StationID.

this is whats in the log:

19:59:20.618 [DEBUG] [oenig.internal.handler.StationHandler] - Initializing Tankerkoenig handler ‘tankerkoenig:station:fd7174cbc1:15aa4433fa’
19:59:20.621 [DEBUG] [oenig.internal.handler.StationHandler] - Refresh job scheduled to run every 24 hours for ‘tankerkoenig:station:fd7174cbc1:15aa4433fa’

still noting changed.

Now it works after

  • deleting the 2 Tankerkoenig THINGs
  • restaring OH3
  • creating THINGs again
  • restarting OH3

Thansk a lot.


I have no real clue what happened to the OP.
I noticed the exact same behaviour ( both remained UNKNOWN) by using a newly created Tankerkoenig Konto thing ( bridge) and a station using the same SationID as the OP.
However redoing the test after some time (last night) both came ONLINE. That happened without deleting the binding and things ( I had things set to disabled) and no restart of OH3.
My personell conclusion: some unknown/ not reported server problem either at Tankerkoenig or even at the MTS-K.
@Matt_Hias Thanks for the final feedback.

1 Like