Configuration files are being placed in "@appstore"-folder

  • Platform information:
    • Hardware: Synology NAS
    • OS: Linux
    • Java Runtime Environment: Java 8
    • openHAB version:
  • Issue of the topic:
    I installed openHAB on my Synology. I can open the openHAB interfaces in my browser, but I want to open the configure folders(think about the things, rules, items(etc) folders) in Visual Studio Code so that I can edit them. After a long search using SSH/Putty, I found them in the @appstore map, but this map isn’t shown in Windows Explorer(because of the ‘@’). This is quite weird, because in the installation of openHAB, I selected a folder(SmartHome --> openHAB) for the installation files.

Anyone knows how to open the configure files in the VS Code?

Hi again Jim!

Having not used the Synology package myself I assume that folder you selected might just be where it downloaded the files it needed to install openHAB, not where it actually installed openHAB.

If you look here:

The documentation says it will put the conf directory inside a share called “public” if one exists.

If you have not done too much with your openHAB setup yet the easiest thing might be to create a share called “public” (in Synology UI: Control Panel → Shared Folder → Create). Then remove the openHAB package and reinstall it so it puts everything in that easier to access place.
Edit: N.B. if you have done a lot you may be able to copy what you have done and restore it in the “public” share but you will probably have to fix files permissions (see the end of option 3).

If you want to go a bit deeper down the rabbit hole of learning the command line you could edit the files over ssh using the command vim. N.B. Vim can be very confusing to beginners; it can be hard to figure out how to even close it!

A third (more complex) option is you could create a link from one of the shares you can access to the /volume/@appstore/openhab2 directory. You will probably run into permissions problems with this one. If you want to take the plunge you will probably want to look up what these commands do:

  • ln -s
  • ls -al
  • chmod
  • chown

Hey Ross!

Searched like the whole internet for this problem and the solution was this simple… thanks mate, wouldn’t be anywhere without you :sweat_smile: