Configuration for a door lock control (relay based)

Tags: #<Tag:0x00007f74546f7cf8> #<Tag:0x00007f74546f7bb8>
  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Rev 1.2
    • OS: openHABian
    • openHAB version: openHAB 2.4.0~20181026171748-1 (Build #1401)

I’m wondering how to best configure a strike lock controller (Popp 012501) .
Currently I have
Switch doorlock “Türöffner” {channel = “zwave:device:5a95239b:node8:lock_door”}
as an item and the thing is configured with the following parameter in Device configuration:
Lock timeout: 3
which I assume should automatically lock (disable the relay) after it was open (enabled relay) for 3 seconds automatically.

In the sitemap I currently have
Switch item=doorlock icon="lock"

Now my questions would be:
Why does the lock timeout not work as expected when I unlock and is it possible to configure it not as a switch in the sitemap because it is supposed to be triggered and lock again automatically? So something like a simple trigger instead of a stateful switch would be nice.

Edit: It also seems I cannot change the device configuration. When I try I do not get an error but in the log I see a second later again:
[mmandclass.ZWaveDoorLockCommandClass] - NODE 8: Door-Lock config report - timeoutEnabled=true timeoutMinutes=0, timeoutSeconds=3
Actually if it would work as I expect it would be ok because timeout is enabled and 3 seconds is about ok. Still wondering why it does not allow to reconfigure it.

I could not find a way to upload a log file here.
I created debug logs for the zwave binding which shows the configuration change attempt in the first part and a few minutes later a “UNLOCKED”-“LOCKED” cycle where the configured timeout does not occur.

The log is here:
https://github.com/openhab/org.openhab.binding.zwave/files/2538159/openhab.log
since I thought this is some kind of bug and therefore opened an issue in github for it.
@chris asked me to add the additional information here as well.

Any hint would be appreciated

Interesting.
I upgraded my snapshot version to the one from 20181111 and now it seems at least that the doorlock timeout can be changed. The value persists now in the habmin interface.
But still the timeout is apparently not applied. Once set to “UNLOCK” it keeps on going. Timeout is now set to 2. I hope this considers seconds and not minutes?
So there is some improvement but it’s still quite inconvenient without the timeout.
@chris, any further comments or ideas?

Thanks,
Wolfgang

Have you got this to work? I just got one and included it into the network. It gets detected, but I cant get ittt to activate after I hav added bindings to it.

No, I’m still struggling. Seems everything works but the relay does not turn off after the lock timeout. It might be just a small issue and I might even be able to fix it via “expire” or something. But currently I hope to get some advice or bugfix at some point.

Ok, i cant even get it to activate. Got it detected and binding items, but cant get it triggered right now.

I guess you run a openhab version where the z-wave binding already supports security (like snapshot)? Otherwise I think detection would not work anyway but want to be sure.

Yes, upgraded yesterday and it gets detected ok.
I think it is something with the item binding hat gets wrong. I don’t get a “switch” icon under control in Paper UI for example.

Indeed. In PaperUI I also get a state selector.
image

where I can switch between Locked and Unlocked.
Probably that is part of the issue when defining the item as a Switch. But I do not know what else to use.
In any case when I switch to “Unlocked” it does not time out.

Is this the device you are using? https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/419

If so, the device db entry is incomplete, so you may want to update it. The manual details the association groups and configuration parameters. The default values for the config params look like they would make the device perform the way you want it to (lock 3s after unlock), but if they were in the db, you could confirm the settings in your device.

@5iver thanks for your feedback and yes that is the device. I have also seen the entry and the “incomplete” state. I’m totally fine to help in completing the entries but I’m quite unsure how exactly to get them and transfer them correctly. Is there any reference howto about that?

ok, found https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide and will try to proceed as explained.

1 Like

Seems I cannot get edit rights for the zwave-device-database.
Can I share the relevant XML from the device somewhere else so someone can help me completing the database?

go ahead :wink:

I guess this is the XML required:
network_dd21954b__node_8.xml (10.4 KB)
?

1 Like

here you go
I fixed some errors and added parameters

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/419

@Dim thanks for your help! The entry says " Supports Security No" while AFAIK this is a secure-only device even.
Is this important?

oops… fixed :slight_smile:
thanx

I did some changes to the Endpoint 0 Classes… I hope they are correct :stuck_out_tongue:

If it works good, let me know, I am also in the market for this device (will buy some stuff like Danalock v3 and similar)

If I understand the process correctly I now need to wait until @chris performs the next database upgrade merge and the binding is updated in SNAPSHOT, right? Or can I fiddle something manually inbetween?

Correct
In theory: Wait till DB is exported (this is automatically done), included in the next Z-Wave build (usually every 24 hours) and grab the latest Snapshot of the Binding (or entire OH2 Snapshot which includes the new snapshot builds of the bindings)

There is an “accelerated” method but I have never done it myself, so I don’t know if this will work:

Export the xml (openHAB2 option) from the DB, modify the Z-Wave jar and replace the existing xml for this device with the exported one

To do this, you will have to uninstall the existing Z-Wave binding, download the latest jar from here: https://ci.openhab.org/job/openHAB2-Bundles/lastBuild/org.openhab.binding$org.openhab.binding.zwave/
open it up using 7zip, find \ESH-INF\thing\popp\012501_0_0.xml and replace it with the exported one (same file name).

Deploy the modified jar as a manual addon