Configuring KNX Gira Dimmer KNX Binding 2.4

  • Platform information:
    • Hardware: Intel Nuc 6th Gen
    • OS: Windows 10pro
    • Java Runtime Environment: 221
    • openHAB version: 2.4
  • Issue of the topic: Cannot get it working / Error Items file

Hi there,
I’ve been experimenting with Openhab and now I’m testing in order to build a KNX home automation with it.

My first setup is pretty simple it’s a Gira IP Router 216700 (firmware 4.xx) and a Gira Dimmer 103100

I’m struggling to get the 2.4 binding configured however so I really hope somebody can help me (and prevent me from switching to IP Symcon :smile: :slight_smile: )
The dimmer is working fine. (I’ve tested with a demo version of Symcon)

I’ve made the following groupadresses in ETS:"
1/1/4 Switch
1/1/5 Increase/Decrease
1/1/6 Strenght of light
1/1/7 Feedback switch

The things file looks as follows: (I’ve been trying several things the past hours)

//ROUTER
Bridge knx:ip:bridge [
type=“ROUTER”,
ipAddress=“224.0.23.12”,
portNumber=3671,
localIp=“192.168.1.53”,
readingPause=50,
responseTimeout=10,
readRetriesLimit=3,
autoReconnectPeriod=60,
localSourceAddr=“0.0.0”
] {
Thing device generic
Type dimmer : Dim_Tuin “Dimmer” [ switch=“1/1/4”, position=“1/1/6”, increaseDecrease=“1/1/5” ]
}

The Items file looks as follows:

Dimmer Dim_Tuin “Dimmer [%d %%]” { channel=“knx:device:bridge:generic:Dim_Tuin” }

The problem is that I’m getting an error reading the items file:

  • Configuration model ‘Knx.items’ has errors, therefore ignoring it: [1,1]: missing EOF at ‘ï’

Can you please help in getting this right?

Many thanks.

Jan

You forgot curly brackets around type. But less is more:

Bridge knx:ip:bridge [
	type="ROUTER",
	localIp="192.168.1.53"  // pretty sure you even don't need this parameter
] {
	Thing device generic {
		Type dimmer : Dim_Tuin "Dimmer" [ switch="1/1/4+<1/1/7", position="1/1/6" ]
	}
}

There should be another GA for getting the dimm level. increaseDecrease should not be used.

Hi Udo,
Thanks very much for helping me.
I adjusted the .things file with the code.
I assume it’s working (no errors in the log after putting the ‘=’ outside the quotes)

I’m still getting the error for the .items file however:

Configuration model ‘Knx.items’ has errors, therefore ignoring it: [1,1]: missing EOF at ‘ï’

Groupaddress 1/1/6 for getting the dim level is not correct? In ETS it’s an output called ‘output light strength’ (translated from Dutch)
What other group address do you mean?

If 1/1/5 for increase/decrease should not be used (b.t.w. Symcon uses this GA), how can the dim level be adjusted then?

Thanks again,

Jan

Jepp, typo when correcting the quotes.

Dimmer Dim_Tuin "Dimmer [%d %%]" { channel="knx:device:bridge:generic:Dim_Tuin" }

seems ok to me. Maybe you have issues with the quotes

“text” vs. "text"

Another thing: Please avoid identical names of channels and items. So better define the item as follows:

Dimmer DimTuin "Dimmer [%d %%]" { channel="knx:device:bridge:generic:Dim_Tuin" }

Ah. There should be two communication objects for brightness, one as output and one as input. openHAB likes to send absolute dimm level. Of course you could use INCREASE and DECREASE as command by using increaseDecrease CO.
There are some dimmers which need start-stop dimming, openHAB does not support this feature.

HI Udo,
I changed the quotes from "to “ in the .items file:

Dimmer DimTuin “Dimmer [%d %%]” { channel=“knx:device:bridge:generic:Dim_Tuin” }

But still the same error:
2019-08-04 14:11:43.588 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model ‘Knx.items’ has errors, therefore ignoring it: [1,1]: missing EOF at ‘ï’

In my understanding I defined 1/1/5 (symcon also sends the absolute value btw) as the GA to send the dimvalue to, and 1/1/6 as the GA to receive the actual dim value from.

Do you have an example how to configure then and how to program an adjustment of the dimmer (or do I still misunderstand?

Many thanks!

Regards,

Jan

But increase/decrease is DPT 3.007 (4bit) while absolute dimming is DPT 5.001 (8bit, 100%, stepsize ~0,4% -> 0 = 0% 255=100%)

This is a snippet of my configuration (but to be honest, I don’t use a router but a knx/IP interface)

Bridge knx:ip:bridge "My knxIP Router" [ 
    type="ROUTER" 
 ]
 {
  Thing device hagerDim1_1_5 "Dimmer 1" @ "KNX" [ 
     ] {
        Type dimmer : ch1 "Strahler Buffet" [ switch="3/5/20",position="5.001:3/5/22+<3/5/27" ]
    }
}

While there is no rule for naming, I prefer a device specific naming.
3/5/20 is DPT 1.001 Switch (no status, because dimmer items use Number as Status)
3/5/22 is DPT 5.001 Set Dimm Level (openHAB will send the level to the device)
3/5/27 is DPT 5.001 Get Dimm Level (openHAB will receive the level from the device)
< is: “hey, openHAB, please read the Value once when starting.”

This is the Item:

Dimmer DimmerGruppe1_Ch1 "Strahler Buffet" {channel="knx:device:bridge:hagerDim1_1_5:ch1",autoupdate="false"}

autoupdate="false" is to prevent openHAB from setting the Item value.