Confused about default setup for Fibaro motion sensor


I am using the 2.3.0 version of the z-wave binding, which may matter here…

Ok. what I am seeing are three things, which may be related (?).

It seems that whatever I do I cannot get proper hold of the motion sensors that I am moving from another network to my new z-wave binding based network. What I mean by properly get hold of here is that I can include the devices fine, and they seem to work ok. I get all the sub-devices and can assign then to rooms and groups.

But, since I don’t want the led giving feedback when I pass by it, I want to disable it. That change in settings never “takes” however. I can apply it, save and wake the device, but I still get the cat eye when I pass the motion sensor.

Also, looking at the association groups, they are not set up properly (at least if I am not misunderstanding something here)

These should all, if I am not mistaken, at least include the openhab controller. And I dont know which nodes these 215 and so on are, since my list of nodes dont go higher than 50 at the moment.

The problem is then that I cant remove them either. I can set the lifeline to openhab controller, and then I get temperature readouts and so on. But, if I try to remove for instance noew_215_0 from group 2, I get an internal server error notification (and no change in the device of course) and I get this in the logs (device 53 is the one I tried to alter)

2018-08-26 09:58:54.875 [ERROR] [st.core.internal.thing.ThingResource] - Exception during HTTP PUT request for update config at 'things/zwave:device:edde6877:node53/config'
java.lang.NullPointerException: null
	at org.openhab.binding.zwave.handler.ZWaveThingHandler.handleConfigurationUpdate( [230:org.openhab.binding.zwave:2.3.0]
	at org.eclipse.smarthome.core.thing.internal.ThingRegistryImpl.updateConfiguration( [108:org.eclipse.smarthome.core.thing:0.10.0.oh230]
	at []
	at sun.reflect.GeneratedMethodAccessor72.invoke(Unknown Source) ~[?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]
	at java.lang.reflect.Method.invoke( ~[?:?]
	at org.glassfish.jersey.server.model.internal.ResourceMethodInvocationHandlerFactory$1.invoke( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher$ [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.invoke( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.model.internal.JavaResourceMethodDispatcherProvider$ResponseOutInvoker.doDispatch( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.model.internal.AbstractJavaResourceMethodDispatcher.dispatch( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.model.ResourceMethodInvoker.invoke( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.model.ResourceMethodInvoker.apply( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.ServerRuntime$ [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.internal.Errors$ [169:org.glassfish.jersey.core.jersey-common:2.22.2]
	at org.glassfish.jersey.internal.Errors$ [169:org.glassfish.jersey.core.jersey-common:2.22.2]
	at org.glassfish.jersey.internal.Errors.process( [169:org.glassfish.jersey.core.jersey-common:2.22.2]
	at org.glassfish.jersey.internal.Errors.process( [169:org.glassfish.jersey.core.jersey-common:2.22.2]
	at org.glassfish.jersey.internal.Errors.process( [169:org.glassfish.jersey.core.jersey-common:2.22.2]
	at org.glassfish.jersey.process.internal.RequestScope.runInScope( [169:org.glassfish.jersey.core.jersey-common:2.22.2]
	at org.glassfish.jersey.server.ServerRuntime.process( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.server.ApplicationHandler.handle( [170:org.glassfish.jersey.core.jersey-server:2.22.2]
	at org.glassfish.jersey.servlet.WebComponent.serviceImpl( [167:org.glassfish.jersey.containers.jersey-container-servlet-core:2.22.2]
	at org.glassfish.jersey.servlet.WebComponent.service( [167:org.glassfish.jersey.containers.jersey-container-servlet-core:2.22.2]
	at org.glassfish.jersey.servlet.ServletContainer.service( [167:org.glassfish.jersey.containers.jersey-container-servlet-core:2.22.2]
	at org.glassfish.jersey.servlet.ServletContainer.service( [167:org.glassfish.jersey.containers.jersey-container-servlet-core:2.22.2]
	at org.glassfish.jersey.servlet.ServletContainer.service( [167:org.glassfish.jersey.containers.jersey-container-servlet-core:2.22.2]
	at com.eclipsesource.jaxrs.publisher.internal.ServletContainerBridge.service( [15:com.eclipsesource.jaxrs.publisher:]
	at org.eclipse.jetty.servlet.ServletHolder.handle( [85:org.eclipse.jetty.servlet:9.3.21.v20170918]
	at org.eclipse.jetty.servlet.ServletHandler.doHandle( [85:org.eclipse.jetty.servlet:9.3.21.v20170918]
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle( [183:org.ops4j.pax.web.pax-web-jetty:6.0.9]
	at org.eclipse.jetty.server.handler.ScopedHandler.handle( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at []
	at org.eclipse.jetty.server.session.SessionHandler.doHandle( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle( [183:org.ops4j.pax.web.pax-web-jetty:6.0.9]
	at org.eclipse.jetty.servlet.ServletHandler.doScope( [85:org.eclipse.jetty.servlet:9.3.21.v20170918]
	at org.eclipse.jetty.server.session.SessionHandler.doScope( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.eclipse.jetty.server.handler.ContextHandler.doScope( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.eclipse.jetty.server.handler.ScopedHandler.handle( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle( [183:org.ops4j.pax.web.pax-web-jetty:6.0.9]
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.eclipse.jetty.server.Server.handle( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.eclipse.jetty.server.HttpChannel.handle( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at org.eclipse.jetty.server.HttpConnection.onFillable( [84:org.eclipse.jetty.server:9.3.21.v20170918]
	at$ReadCallback.succeeded( []
	at []
	at$ []
	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.executeProduceConsume( [87:org.eclipse.jetty.util:9.3.21.v20170918]
	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceConsume( [87:org.eclipse.jetty.util:9.3.21.v20170918]
	at [87:org.eclipse.jetty.util:9.3.21.v20170918]
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob( [87:org.eclipse.jetty.util:9.3.21.v20170918]
	at org.eclipse.jetty.util.thread.QueuedThreadPool$ [87:org.eclipse.jetty.util:9.3.21.v20170918]
	at [?:?]

So, I really cant get beyond the current state at the moment.

I should also add that I am seeing this in the logs. May be totally unrelated, but I cannot tell so I am including it here just the same - if it matters.

2018-08-26 10:15:22.854 [ERROR] [tocol.commandclass.ZWaveCommandClass] - Error extracting value - length=8, offset=6, size=7.
2018-08-26 10:15:22.915 [ERROR] [tocol.commandclass.ZWaveCommandClass] - Error extracting value - length=8, offset=6, size=6.
2018-08-26 10:15:23.158 [ERROR] [tocol.commandclass.ZWaveCommandClass] - Error extracting value - length=8, offset=6, size=3.
2018-08-26 10:15:23.434 [ERROR] [tocol.commandclass.ZWaveCommandClass] - Error extracting value - length=8, offset=6, size=3.
2018-08-26 10:15:23.553 [ERROR] [tocol.commandclass.ZWaveCommandClass] - Error extracting value - length=8, offset=6, size=3.

Any ideas on how to get hold of my motion sensors - they are included but not in my reach somehow…

I used to encounter that behavior at times, too, but cannot explain.

First, re-initialize your node(s) using habmin. That(if successful) should remove those latter warnings you’re seeing. That might or might not help with your problem.

If it does not, to get rid of those “fake” associations, you can edit the jsondb (/var/lib/openhab2/jsondb/org.eclipse.smarthome.core.thing.Thing.json). You can right replace the fake nodes with the controller’s ID. But play it safe, i.e. shutdown OH before, and take backups of your full config, and safety copies of the jsondb file.

Not sure what to make of this (and sorry for altering the topic of the thread somewhat).

It seems that even in working devices, I get associations inserted (by the binding?) no matter what I do. In a well behaving node, I am able to insert the controller node into Lifeline. Then I will have associations to “node_202_0” or something like that in all other association groups. Now, I can “remove the tick” in the PaperUI GUI and get everything neat and tidy, but once I save the edits, there will be new associations to “fake” nodes (“node__0”) in the groups.

Is this normal behavior? Any ideas about why this is happening?

No it is not and as I wrote I don’t know why it is happening, but I explained how to fix it.

I have about 10 fibaro motion sensors in my home, had my fair share of problems with them.
Anyway once properly included they function very well and have a lot of flexibility.

Would do the following:

  1. Use habmin and not paper ui when you configure you zwave devices
  2. Exclude it. Factory reset it and then include it again just to be sure. If it cannot be included, factory reset it.
  3. When including it, wake it up manually by double clicking the button
  4. When changing config and setting association groups, wake it up by double clicking it, otherwise
    it will take a lot of time before it wakes up and the settings will be applied.

Regards, S

Yes, sorry. I will look into doing that procedure. Do the “ghost” nodes come back if you change something in the Paper UI GUI after having edited the nodes away in the json files?

Thanks. I will try this also, as I have tried steps 2-4 as part of my earlier attempts.