Confused about z-wave exclusion


I am migrating a network from one network homeID to a new one. I am using the same controller card, but now managed by the z-wave binding. I chose this method rather than excluding everything then including again because I have a large-ish network and need to set everything up in steps. And in the mean time, I need some associations to work, so while my strategy is not perfect I at least managed this.

Anyway, I find myself quite confused about the exclusion that I need to do for each device in order to include into openHAB. It seems that setting the controller in exclusion mode for devices that are not a “thing” in OH already is something you do in habmin. Or is there another way? The reason I ask this is that I am confused about the feedback of habmin when it comes to exclusion. Often I get no feedback that the exclusion went through. If I am lucky then, the device is one of them that behaves differently when they are not in a network - like the Fibaro Dimmer 2 which will gradually dim up and down when not included. That way I know. But, for other devices it can be hard to tell and I then need to try to include the device multiple times, or exclude multiple times in iteration to eventually get things working.

The “multiple times” part is tiresome, and I have just started on the project of moving ~ 80 devices over, so if there is a better or more verbose way of doing this, I would appreciate the information.

If I understand you, you are still using the same controller, so why do you need to exclude the devices at all? You only need to exclude if you change to a different network controller… Maybe I misunderstood?

No. You are correct, but in this case I had everything included in Z-way securely…

Ah - ok, then you will need to exclude or reset them…

HABmin is the best way to exclude - you can in theory do it in PaperUI as well, but there will be absolutely no feedback. HABmin will provide you a popup if the device was excluded - of course, if it’s not excluded, there will be no such popup…

You will have to have the devices within range of your controller to exclude them - put HABmin into exclude mode, then put the device into exclude mode within 30 seconds. Repeat this for every device you want to exclude.

Your other options if you have a lot of devices is to factory reset the devices and the controller. This might be quicker?


Thank you for your input. I am seeing about 1/5 - ⅓ of cases where the devices is actually excluded, but habmin tells me nothing (or something different). The Fibaro dimmer 2 devices are good for spotting this, because they will start dimming up and down once they dont belong to a network. Many of them are then excluded, but I get no feedback from the binding / habmin (I am on openhab 2 stable). Thermostats are also good for spotting this, since at least mine (HeatIt) give feedback when they considered themselves excluded from the network. I know now not to trust the feedback from habmin / the binding so I try to exclude two times, and if I get no feedback (and it is not one of these devices) then I try to include. And sometimes it work.

Yes, this is quicker. And am starting to love Fibaro now for including this option in all of their newer devices. I wish all of them had a reset option that is not based on performing an exclusion.

The binding will only give feedback of course if the controller tells the binding that a device is excluded - this might not always happen either…

As far as I’m aware, all devices should have such a feature. I have some very old Fibaro devices, and for sure they have a reset function and I don’t think I’ve seen any device that doesn’t have some way to reset to factory defaults (but maybe there are some - would be strange though).

You maybe right actually. I did not notice that they seem to all have a reset functionally somehow.
The Qubino one is awkward, basically like an exclusion, but resetting devices seems like a good strategy overall.


Can you explain why this is a problem? I have a UZB which is being used by Z-way and I was hoping to move it over to openHAB without having to exclude/include every device. This may throw a wrench into my plans, so I would like to get more information. Is this not possible because of secure inclusion with Z-way for some reason?

The issue is the “securely” part - since the current master branch, which I think was being used here, doesn’t support security, this is not possible without resetting the devices.

If you haven’t securely included device, or if you use the development binding, then this shouldn’t be an issue.

I can report that so far I am very happy with the stable binding. Much less sluggish than the Z-way setup I had before. Now, the issue in Z-way may have been also that I had everything included securely. Now, since the version of the z-wave binding I am using does not support it, I am not including devices securely. So, this could also be part of the fantastic improvement that I am seeing.

Anyway, I just wanted to say that I am very happy with the performance of my system. Not all devices have been included yet, but enough to convince me that this will work…