Connection dropped by Server Mail Binding

Hello I have set up the Mail Binding like in the the docs described.
I have now struggle with the error

`2020-03-05 16:00:13.971 [INFO ] [inding.mail.internal.POP3IMAPHandler] - error when trying to refresh IMAP: Connection dropped by server?`

I am using Gmail. Maybe someone know how to solve it?

Thank you.
Mark Baumann

I have already IMAP activated in the Gmail Settings.

got same problem…

No one has yet provided their configuration details. Not much chance anyone can help without those…

@Carmine_Di_Biase @markymark

1 Like

You are definitely right. That’s my things file:

Thing mail:smtp:googlesmtp [ hostname="", port="587", from="", sender="", security="TLS", username="xxxxxx", password="xxxxxx" ]

Thing mail:imap:googleimap [ hostname="", port="993", security="SSL", username="xxxxxx", password="xxxxxx" ] {
        Type mailcount : inbox_total [ folder="INBOX", type="TOTAL" ]
        Type mailcount : inbox_unread [ folder="INBOX", type="UNREAD" ]

I’ve no problem in sending mail; in paper ui panel the imap seems to be online, but on the log file I see the error above.
I tried putting the email account password, the two-factor authentication password and I also tried putting a wrong password and I get always the same error

Make sure you’ve enabled “less secure app access” in your google settings. Per their docs:

Because less secure apps can make your account more vulnerable, Google will automatically turn this setting off if it’s not being used.
1 Like

I’ve tried, but doesn’t solve the problem

Does someone has this binding and it works?

I’ve seen some references indicate that the protocol needs to be imaps instead of imap. In which case the binding may need an update to allow for that in the thing definition.

1 Like

I have the same problem with:

Bluewin Mail provided by Swisscom
Outlook Mail
iCloud Mail

For iCloud I generated an application specific password.

For all of these accounts I get a warning as described here

Does anyone have a solution for this problem?

I have enabled DEBUG mode, but do not get any additional entry in the log files.

1 Like