Connection refused after installation

  • Platform information:
    • Hardware: Synology DS110+
    • OS: DSM 5.2-5967 update 8
    • Java Runtime Environment: Java SE Embedded 8 version 1.8.0_6-0041
    • openHAB version:
  • Issue of the topic:

I had a running installation of openHAB on my Synology, but had some issues with it. So I reinstalled openHAB. I chose the option to have the configuration in Synology folder Public/Openhab, with port 8080.

However, after installation, http://(synology IP):8080/start/index gives a “connection refused” error.

Things I already tried

  • stop/start package
  • reboot Synology
  • re-install the same package
  • re-install package
  • installed again with port setting 8081
  • checked any Synology firewall settings, but nothing blocking port 8080 or 8081

All of this gave the same result, so I’m stuck right now. Any suggestions on other things I can try to get the install working again ?

Many thanks !

Check that the port is listening on the correct interface on the Synology box.

netstat -na | grep 8080

If it is, try to telnet from a computer

telnet synologyIP 8080

This should confirm if the webserver is up, attached to the IP you expect (it might be bound to all) and that your router / Nas is allowing connectivity.

@NicGray Thanks for your answer.

Nothing is returned from netstat -na | grep 8080
I checked Synology’s firewall, no ports are blocked.

I reinstalled DSM as well, but without result.

If nothing is listening on 8080 then it would suggest that the webserver is not running (or is running on a different port). I’m not that familiar with running it on Synology ( although I have one ) so would suggest checking that it’s actually running, no errors in the logs, etc.

I assume that it should run as a java process so check it is running:

ps -ef | grep java

You should see all the arguments that point to it being openhab even where the web port is assigned (.service.http.port=8080) if it is running you can see what ports it is using with

sudo netstat -nap | grep JavaPIDyouGotAbove

Thanks for the feedback Nick. I couldn’t get it to work on my Synology, so bought a dedicated Raspberry Pi which is running smoothly now :slight_smile:

Yeah, dedicated is better and the Synology OS is kind of limiting when it comes to linux tools and packages (i.e Grafana, nginx)