Connection to myopenhab does not succeed

myopenhab
Tags: #<Tag:0x00007f6ce8d33428>

(Martin Mois) #1

I have setup openhab 2.2.0 on my RaspberryPi2, installed the openhab cloud connector and configured it (mode, baseUrl and selected items in Paper UI). I have created an account on myopenhab.org and configured UUID and secret.

But the myopenhab.org stil says that I am offline. Turning the debug log in Karaf console on, shows the following log lines:

2018-02-10 20:48:14.854 [DEBUG] [io.socket.client.Manager            ] - opening https://myopenhab.org:443/
2018-02-10 20:48:14.857 [DEBUG] [io.socket.client.Manager            ] - connection attempt will timeout after 20000
2018-02-10 20:48:14.860 [DEBUG] [io.socket.engineio.client.Socket    ] - creating transport 'polling'
2018-02-10 20:48:14.863 [DEBUG] [io.socket.engineio.client.Socket    ] - setting transport polling
2018-02-10 20:48:14.866 [DEBUG] [t.engineio.client.transports.Polling] - polling
2018-02-10 20:48:14.870 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr poll
2018-02-10 20:48:14.872 [DEBUG] [ngineio.client.transports.PollingXHR] - xhr open GET: https://myopenhab.org/socket.io/?EIO=3&transport=polling
2018-02-10 20:48:14.875 [DEBUG] [ngineio.client.transports.PollingXHR] - sending xhr with url https://myopenhab.org/socket.io/?EIO=3&transport=polling | data null
2018-02-10 20:48:15.006 [DEBUG] [io.socket.engineio.client.Socket    ] - socket error io.socket.engineio.client.EngineIOException: xhr poll error
2018-02-10 20:48:15.010 [DEBUG] [io.socket.client.Manager            ] - connect_error
2018-02-10 20:48:15.013 [DEBUG] [io.socket.client.Manager            ] - cleanup
2018-02-10 20:48:15.021 [DEBUG] [io.socket.client.Manager            ] - reconnect attempt error
2018-02-10 20:48:15.025 [DEBUG] [io.socket.client.Manager            ] - will wait 5000ms before reconnect attempt
2018-02-10 20:48:15.028 [DEBUG] [io.socket.engineio.client.Socket    ] - socket close with reason: transport error
2018-02-10 20:48:15.031 [DEBUG] [t.engineio.client.transports.Polling] - transport not open - deferring close

A simple “curl https://myopenhab.org:443” shows that the connection to the server is successful from my RaspberryPi.

A “curl https://myopenhab.org/socket.io/?EIO=3&transport=polling” returns this JSON document:

{"code":0,"message":"Transport unknown"}

Any ideas?