Console keeps asking for a password?

Hi - I’ve just entered the world of openHAB and wow amazing job to the founders and community, what a great capability you have built.

I have a basic question, I am attempting to secure openHAB before I start having some real fun with it.

I am using SSH into openHAB using PuTTY to follow steps in this guide:
adding users, certificates etc.

I start the session entering my username and password which connects me successfully however:
Every time I put a command into this session it asks me for a password.
I’ve attempted a few passwords related to the system including the one I logged in at the start of the session but I get Error login failed.

Help please. Thanks

Hardware: Synology DS216
DSM version: 6.2.1-23824 Update 6 (latest available)
Installation file: openHAB v2.4.0.001 Synology DiskStation Package
Java 8 already installed

Welcome to the community.:smiley:

The default username/password is openhab:habopen , so enter habopen at the password prompt.

1 Like

Hi there - thanks for such a fast response.
So as part of securing the system I had already changed the password for openHAB by doing the following:
• I used PuTTY SSH pointed to the synology as root user
• Found and edited using vi (wow that was an experience) and changed the password to something else in plain text
• I write the file (:w), quit (:q) and reopen and I notice that there is a crypt in the password field and not my new password in plain text
• I close my session and I connect SSH into openHAB SSH port with the new password and it connects successfully

But after that successful connection with the new password I get the issues in my original post.

Maybe I should try to change the password back to default and see if that clears the issue?

ok I changed the password back to defaults.
I am able to connect and start the session with the default password.
but when I enter commands, it prompts for a password, for which I put in the default password, and get the same error.

Try using the openhabian tool to the change password. If you can still access it, the command is sudo openhabian-config then check out all the options till you find where to change passwords.

can’t seem to run it. I’m going to reinstall openHAB and this time not mess with the password until later down the line. Let me see if a fresh install does the trick. Thx

After the fresh install, test changing the password using the openhabian config tool.:wink:

still not working, same issue.
Just in case… where am I sending the command sudo openhabian-config?
This is in the openHAB SSH session right?
Still asks for a password, which I put in the default and says its invalid.

Yes from the command line, see below. The default password for this should be openhabian.


Hi - I looked it up and if I am correct this is used for Raspberry Pi SSH.
I’m using synology NAS. Is it possible to use openHABion on synology installations? thx

Never used OH with synology but if sudo openhabian-config doesn’t open the tool then I guess not.:thinking:

It all depends what you did install!
openhabian is a complete installation with OS and all needed for openhab. If you just installed openhab and its dependencies on an running OS you simply do not have it.

I’m tempted to stop troubleshooting on my synology nas and put this on a pi.
A few questions on OH on pi…
which pi model is best for this type of project?
and is it possible to setup SSL and your own domain pointing to OH using the pi version of OH?

The first part of the question depends much on your setup.
OH does run for me on raspi3B, my hardware setup consists of about ten mqtt devices andsome sonos boxes. As binding I have in use: network, systeminfo, sonos, Matt and tankerkoenig, together with persistence mapdb and rrd4j and for the tts output voicerss.
All running with no issues, a larger setup, with more bindings, an internal voice setup could bring the raspi at the edge I have to guess.
The second of your question, I can’t answer.

ok I think it’ss be worth a try. I have a 3B spare so I’ll give that a go.
Any advice on suitable storage capacity for the micro SD please?
Thanks again

Reading the Documentation gives you:

(16GB or more to support wear-leveling)

So i got around to installing openHAB on Pi 3 and wow that was a breeze compared to attempting it on the synology NAS. Pi working great. Thanks all

Hi, I’ve successfully installed openhab on a Synology Diskstation and everything is working great. I however wish to install some additional components using the openhabian-config and am getting the same “login-failed” issue for sudo as Pascal. As above, I can SSH into openhab fine, just can get the password for sudo. Any ideas?

UPDATE: After much research, I’ve found another way to install the Mosquitto component (instead of using the openhabian-config), by using a Synology Diskstation package available from the Synocommunity.

However it would still be good to understand why the default sudo password does not work.