Could not create rrd4j database file (Read-only file system)

So I was just right now adding an items file with 137 items (OWM Weather binding) and suddenly my openhab.log exploded with messages like:

  • Could not create rrd4j database file '/var/lib/openhab/persistence/rrd4j/<ITEM>.rrd': /var/lib/openhab/persistence/rrd4j/<ITEM>.rrd (Read-only file system)

Got those messages for all my items.

Seems like the file system really is read-only:

Doesn’t seem to be full (yet):

Is this another SD card failing or what else could be the problem here?

  • Platform information:
    • Hardware: Pi 4
    • OS: openhabian 1.6.3
    • openHAB version: 3.0.1
1 Like

This may be a zram problem, what is the output of zramctl if it is what I think it is then all you have to do is simply uninstall and reinstall zram as it was a bug in the code that has since been fixed.

Thanks for looking into this. Output is:


Uninstall/reinstall: sudo apt-get remove zram // sudo apt-get install zram ?

Hmm, it may be the problem I’m thinking of. Go ahead and try uninstalling zram and reinstalling. You can use sudo openhabian-config menu option 38 to do so. As a secondary debug step, what does your RAM usage look like?

1 Like

After a reboot, RAM usage is now:

After uninstall:

After new installation:

After a reboot:

It it supposed to look like this now?

The reboot seems to have fixed the error from appearing (for now?).

Yes, that looks correct. Hopefully it will be fixed forever now.

i had just 1 sonoff POW that made troubles and tried Option 38 and now all my files have this ERROR :sob: :sob: :sob: :sob:

before i had

2021-08-20 00:55:52.668 [ERROR] [d4j.internal.RRD4jPersistenceService] - Could not create rrd4j database file '/var/lib/openhab/persistence/rrd4j/Sonoff_POW_1_ReactivePower.rrd': Invalid file header. File [/var/lib/openhab/persistence/rrd4j/Sonoff_POW_1_ReactivePower.rrd] is not a RRD4J RRD file

now i have (no space left on device)
lol , its a 128 GB SSD

2021-08-21 00:48:04.176 [ERROR] [d4j.internal.RRD4jPersistenceService] - Could not create rrd4j database file '/var/lib/openhab/persistence/rrd4j/HUE_Wohnkuche_TV_Lowboard_Farbtemperatur.rrd': /var/lib/openhab/persistence/rrd4j/HUE_Wohnkuche_TV_Lowboard_Farbtemperatur.rrd (No space left on device)

No the (now full) zram device is in RAM.
You have moved to an SSD. That is not supported for openHABian, and you should have disabled zram as the docs indicate.

PS: mind the forum rules please. Open a separate thread as your issue is unrelated to the OP. Do not address people. And no screenshots please.
How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

oh i have overseen this, sorry markus!

ok i have done that, but couldn’t find a solution while waiting for answers, sorry.
my thread is here

Same problem with read only Filesystem for me.
Raspi RP4B 4GB
openhabian V1.71
openhab V3.2

Solved with this guidance