Couldn't transform value in label / MAP

I found several posts with a similar problem “but” they are solved. Nevertheless, in the stable version from today I have still the problem that …

The transformation function in item with “map” are not working with the following log entry:

22:33:56.309 [WARN ] [.core.transform.TransformationHelper] - Cannot get service reference for transformation service of type MAP
22:33:56.312 [WARN ] [ui.internal.items.ItemUIRegistryImpl] - couldn’t transform value in label because transformationService of type ‘MAP’ is unavailable

The item file looks like:
Contact Smokedetector_Wohnzimmer_okay “Rauchmelder ist [MAP(]” (gModbus,gSmokedetector) {modbus=“smokedetector:0”}

And the smoke is like:

Any solutions for me?

Thanks a lot!

Is the MAP transformation service installed?

Depending on which package you chose you may have to install it.


You are right, but simple installing is not possible:
21:45:17.212 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-transformation-map’: Error

… Any ideas?

Thanks a lot!

There shouldn’t be a problem installing that or any other addon. How did you try to install it?

Try restarting OH and trying again.

… I already did it. I tried to install via PaperUI.

I get the same error message while OH starts.

1 Like

… please, see my other posting concerning the installation of add-ons…

@Sprocky Have you tried to install anything/everything via the addons.cfg file?

If it is enough to add in addons.cfg the entry transformation = map then I did. I restarted OH2. The long messages are the same…


You have to add ALL of your addons to addons.cfg. If you just added map then all the rest of your addons will be uninstalled.

1 Like

… then this is not my preferred way … Let’s stay at the OH2 style :wink:
Does anybody have an idea? The raspberry has full access to the internet…


Using addons.cfg is OH2 style too.

After trying different this and also a reinstall from the zip-file without success I installed the package on my raspberry… And what a surprise … everything is working …

I can not figure out the problem but for now its done for me.


Today I installed openhab 4 on a fresh openhabian device. Afterwards I restored my openhab 3 configuration.
Now I always get hundreds of warnings like

2023-07-28 22:36:45.841 [WARN ] [s.internal.SingleValueTransformation] - couldn’t transform response because transformationService of type ‘JS’ is unavailable

I already installed several transformation services and restartet openhab but the warnings remain. Any ideas how to fix it?

JS Transformation was used in oh3, it isn’t part of oh4, hence the WARN.
You do get the WARN because you restored the oh3 config in which you used this transformation.
To solve it, read Here

1 Like