Cree Connected Bulb Dimming but not Off

I have recently started using openHAB and just installed a number of cree connected bulbs yesterday. The bulbs are connected directly to openHAB through an Ember zwave/zigbee adapter and paired without issue.

I created a Dimmable type item for each bulb in an items file and have added tagging for HomeKit. Through PaperUI I connected each bulb with an item and at first glance thought everything was working perfectly through both the openHAB UI and HomeKit. Once it got dark and I turned bulbs off however I noticed that the lights were not actually off but maintained a very low dimness level. While the light at this level is essentially unnoticeable, the bulb is still on. After some reading I am thinking I might need to add a switch item to each bulb but am not sure if that is going to work given the bulbs are only presenting a Level Control channel to openHAB. As a quick test I added a switch item in PaperUI and connected it to the Level Control channel of one bulb and while it did control the light, the bulb remained in the same state as before when it was dimmed to 0%. This behavior was common between three bulbs.

From what I can tell, adding a switch should resolve this problem but I think the switch needs to be connected to an On/Off channel to send the right command (maybe I am wrong). The only other thing I can think to do is to reset each bulb and try pairing them again. If someone could point me in the right direction I would really appreciate it.

I think it was like this, a switch sending to a dimmer channel will translate ON/OFF to the last stored % value. Imagine it like this, if you turned the Dimmer to 80% and turn it off.
A switch command to ON will result in 80% Dimmer level…
A switch command to OFF will always result in 0%

I tested this behavior with a Phillips Color Hue

I have now added a switch item and connected it to the Level Control channel for one of the bulbs. As you suggested, this has allowed the bulb to return to its last dimness level, though it seems to take a minute or so for the correct level to be displayed both in PaperUI and in the Home app. What this has not solved however is the bulb not fully turning off. It does not matter if the bulb is commanded off with a switch or if it is set to 0%, the bulb is still very dimly lit. Fortunately it is so dim that the light is hardly noticeable but it would be nice for it to actually be off.

My lights.items for reference, if it matters.

Dimmer OfficeLamp_LevelControl           "Office Lamp"            <light> (Office)      ["Lighting"]
Dimmer BedroomLamp_Left_LevelControl     "Bedroom Lamp Patrick"   <light> (Bedroom)     ["Lighting"]
Dimmer BedroomLamp_Right_Level_Control   "Bedroom Lamp Anastasia" <light> (Bedroom)     ["Lighting"]
Dimmer LivingRoomLamp_Table_LevelControl "Living Room Table Lamp" <light> (LivingRoom)  ["Lighting"]
Dimmer LivingRoomLamp_Floor_LevelControl "Living Room Floor Lamp" <light> (LivingRoom)  ["Lighting"]

Switch OfficeLamp_OnOff                  "Office Lamp"            <light> (Office)     ["Lighting"]
Switch BedroomLamp_Left_OnOff            "Bedroom Lamp Patrick"   <light> (Bedroom)    ["Lighting"]
Switch BedroomLamp_Right_OnOff           "Bedroom Lamp Patrick"   <light> (Bedroom)    ["Lighting"]
Switch LivingRoomLamp_Table_OnOff        "Living Room Table Lamp" <light> (LivingRoom) ["Lighting"]
Switch LivingRoomLamp_Floor_OnOff        "Living Room Floor Lamp" <light> (LivingRoom) ["Lighting"]

Hi, please help me. Did you solved your Cree Connected issue? I am planning to buy the same hardware you have?