Current openhab-addons mvn build fails

Tags: #<Tag:0x00007f745a6925a0>

Dear Community,

I tried to build openhab2-addons directory by using “mvn clean install -e -X” and got an error on the first possibility, see attached file. What went wrong?

Best regards,
Jochen

Looks like you’ve typed “lean” instead of “clean”?

Oh dear - it is late, indeed it’s been a typo.

So now, the command was correct, but the build failed, anyway.

See my picture below

It fails to download because it cannot connect to https://jcenter.bintray.com. Is your DNS working properly and can you open it in your browser? Maybe you have a firewall or antivirus solution that is blocking Java from accessing the Internet?

Thanks - now I was able to run the addons build successfully until the transformation service. That took almost 6 hours (called “mvn clean install -e -X”)! Fur further information see my picture below, it seems one of the tests was broken.

There is some progress here! :slight_smile:

The first build might take a while because it will download a lot of dependencies from the Internet. After that most of them will be cached in your local Maven repository ~/.m2/repository

I rarely build using -e -X because it will generate a lot of debug logging that further slows down the build.

It’s a known issue on Windows that those MapTransformationServiceTest fail see openhab2-addons#5854. A workaround might be to skip test execution with a full build by adding the following build option -DskipTests=true

To furthermore speed up your build you can disable static analysis by adding -DskipChecks see also the Developer docs.

Usually I add both options on full builds and omit them when building individual projects to have in depth reporting/testing. Only when I do something else I run full builds with all checks and tests. That’s Jenkins job. :wink:

Build successful (in 30 minutes …): “mvn clean install -DskipTests=true -DskipChecks=true”

2 Likes

The failing MapTransformationServiceTest on Windows should be fixed soon! :slight_smile: