CUXD Timer TIMER GET only shows "Timer Start Value"


I tried to build a countdown based on an CUXD Timer on the CCU2 (Raspberrymatic),
but when I displayed the Item linked to “TIMER_GET”, only the start value of the timer
but no changes…

In a script on the homematic ist works fine.

Any Idea ?

Thnk you.


It is awfully hard to suggest anything without any details at all about your OH. What version? What binding? Items? Rules? Scripts?


sorry, binding ist - like the “tag” - "homematic- Bindung (version binding-homematic - 2.2.0.SNAPSHOT - no idea how to find the exact Build version).

OH Version : openHAB 2.2.0~20171116035510-1
on Raspberry PI (Openhabian 1.3)

I tried to show the changing value with the “dummy widget” on habpanel.
Because the CUXD Timer is an device, there should be an automatic update/event from the CCU.


Items? Rules? Scripts?

If you don’t have any of these then that is your problem. You need to link the channel from the Thing representing the Device to an Item and then use that Item in HABPanel.

I don’t know this device nor do I know this binding but just because there is a Thing and the Thing has Channels does not automatically mean that the device reports its current state. For example, I have Zwave Switches that I can send commands to turn on and off but when I flip the physical switch that does not get reported to OH. So you cannot just assume that communication is two way.

That is no Solution for the CuXD Timer … but a Solution for you Problem.

Use the Expire Binding :slight_smile: