Daikin wi-fi adapter BRP072C42 not visible or configurable in OH

Tags: #<Tag:0x00007f617a995380> #<Tag:0x00007f617a995268> #<Tag:0x00007f617a995100>

Thanks for testing. Yes the Ignored thing is because it matches the ones that already exists (based on the “host”), however you can still add them. When you add one, it should default to secure=on, and it will generate a uuid based on the MAC of the adapter, so the generated uuid will be unique for each adapter. So for a new user, they just need to enter their adapter’s key and in theory it should all work from there, including registering the uuid.

The latest PR review triggered another code changes… hopefully it won’t affect functionality. I won’t ask you to test again until the final PR :slight_smile:

I had a quick look at @kbecker’s code. It uses web socket and the “end points” are totally different to the air conditioner stuff covered in the current Daikin binding.

In my opinion though, I suppose the Openhab’s “Daikin” binding should support the Altherma as well, naturally using a different thing type. I wonder if @kbecker would like to take on the task of integrating his code, since he has the adapter to test and he’s already familiar with it.

Ok. Just ping me and I will test the final version.
Thanks!

1 Like

@madsing please test rc1
org.openhab.binding.daikin-2.5.5-SNAPSHOT-rc1.txt (65.0 KB)

The PR has been merged

I have tested the rc1 and it also works well for me.
Note: In addition,I have removed my daikin.things file then tried to discover and add the adapters. Discovery works fine, but after adding the Thing corresponding to a Daikin BRP072C42 adapter it stays offline. It has configured the Thing with secure=true and a new uuid, but I don’t see a way to input the key from the Paper UI. Maybe that’s the reason.

You’d have to go to Paperui -> Configuration -> Things -> Daikin AC Unit (x.x.x.x) -> Click the Edit button and enter the key in there.

Apparently there’s a way to prompt for the key right after adding it from Inbox but I’d have to create a new thing type in order to maintain backward compatibility with BRP072A42. So do you think it should be done or just keep it this way?

Sorry, I checked again this morning. This is a screenshot taken after clicking the Edit button. Is it where I have to enter the key? (It works fine for me with the key in the .Things file, I am just trying to make it work with the Paper UI). Thanks again.

That appears to be the old binding. Check your karaf console, it should say something like this:

openhab> bundle:list -s | grep daikin
303 │ Active │  80 │ 2.5.5.202005040523      │ org.openhab.binding.daikin

Maybe try clearing your openhab cache?

265 │ Active │ 80 │ 2.5.5.202005040523 │ org.openhab.binding.daikin
266 │ Active │ 80 │ 2.5.0 │ org.openhab.binding.daikin

Do I have two bindings installed at the same time?

Try:

bundle:uninstall 266

Alternatively, uninstall via paperui. The one in the addons folder will not show up in paperui.

Ok. Now it works. So it was an installation problem on my side. I can input the key in the Paper UI, the Thing is updated, but I get an internal error 500 Exception during HTTP PUT request. I think I should restart and try again.

Thanks for your help. I have my AC’s working perfectly using the new binding.

This has now been included in 2.5.5, so you can just delete the jar in your addons folder and upgrade to 2.5.5 and install the binding the usual way e.g. via paperui.