Danalock not reporting status

Tags: #<Tag:0x00007f432d728c20> #<Tag:0x00007f432d7289c8>

Sorry for not answering last day.

Yes I have the V3-BTZE

I’ll try the new device in a few hours.

I’ve not updated the binding since Saturday so the latest changes aren’t yet included. I will try and do an update tonight to push these through.

Ok. Anyhow I’ve downloaded the Build #39 but I have issues even with the Paper UI to get installed. So I’ll wait till tomorrow.

Thank you,
Zsolt.

You do not install it with the Paper UI.
Uninstall the current binding.
Place the downloaded jar file in the addons folder (usually /usr/share/openhab2/addons) & restart OH.

I was talking about the paper Ui service to not get installed on a newly downloaded zip from Ci. I could not open paperui to install the binding itself as the Ui was not installed at all. Maybe I was not expressing myself clearly, sorry for that.
By the way where am I downloading the latest zwave jar from? Is it on the Ci server? I can only find the jar file containing all addons zipped together. (unzip and copy from that?)

Thank you,
Zsolt.

I would either use the install script
Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

or get it from here.

https://ci.openhab.org/view/Integration%20Builds%20(2.5.x)/job/openHAB2.5.x-ZWave/

1 Like

Thanks.

That makes things much easier.

1 Like

I will try and do an update tonight to push these through.

I do not want to disturb you guys in any way but I don’t see the updated binding.
Last CI build is before your answer. Z-Wave build #14

Am I correct?

I’ve tried to install HomeAutomation. Their V3-BTZE device has 2 additional channels, some kind of Alarm state and report which is not present in current binding (I could not get more info of it). Might this be the root cause of NONCE errors? (Two separate channels updated by the lock but the binding only expects one channel to be reported and mixes NONCE IDs?) I way far from debuging any java source code (I only have some .NET experience) so ingore this if I’m totally wrong.

HE apparently did not have time to export the database. I verified by checking GitHub.

Thats ok, thank you!

Can I get the repo URL, to check it for myself later? Or is it a private one?

I check the date here. It goes here before the build picks it up.

Hi!

I’ve just downloaded the latest CI build and the latest binding and I can confirm, the lock is reporting back. There is no NONCE security errors in the log, only I found four of <NODE 2: SECURITY_ERR No valid NONCE! null> error messages which does not affect the expected behaviour.

Here is the log for reference, if needed.
ZWave.part0.log (1023.9 KB)
ZWave.part1.log (1024.0 KB)
ZWave.part2.log (1024.0 KB)
ZWave.part3.log (1024.0 KB)
ZWave.part4.log (823.2 KB)

Thank you for your effort with this, and for the quick solution.

Best wishes and regards,
Zsolt

2 Likes

Sorry, I was too early.

I have a new security error: <SECURITY_ERR Failed authentication!> Displays 8 unmatched hexadecimal numbers. I continue the logs:

ZWave.part5.log (1023.9 KB)
ZWave.part6.log (496.0 KB)

And again the UI failed to reflect the lock status change.

Zsolt.

Well, if it fails authentication, then it won’t show the lock status.

Hi!

Still got several NONCE ID invalid errors.

ZWave.part7.log (1023.8 KB) ZWave.part8.log (564.3 KB)

Thank you.

I don’t see any problem myself. Can you provide a short log that is actually causing you a problem.

The nonce issues that I see in the log are caused by packets being received twice, and not decoded the second time.

Hi @chris !

Sorry to resurrect the post but I still have some minor issues with my Danalock.

If I issue a command from the console to unlock/lock Danalock the item states are updated 3 times (ON->OFF->ON or vica versa depending on the initial status). This comes through the event bus to my rules and makes some hard time to figure out the current status of the lock. In real wolrd the lock only turns once.

I think the main cause is that the polling starts too soon and sees the status of the thing not started to turn yet and reports back the startup status too early. I attach the log of Z-Wave DEBUG and the relevant lines of the events.log.

Can you implement some wait code before the polling starts (I assume there is some devices with momentum and needs some time to reach the intended state)? Or any other method to correct this? Do I need to prepare my rules to handle this? (this may force my rules to be much more complex)

ZWave1.log (100.9 KB)
events1.log (446 Bytes)

Thank you!

Please just change the command poll time to something longer to suite the needs of your device. This defaults to 1500ms (if I remember correctly) but can be set up to 15 seconds, and if set to 0 can be disabled all together.

I’ve tried to change it to 2500 ms than to 3000 ms on PaperUI but there is no effect. The log says it received a config update but the value defaults back to 1500. I tried it twice. And I noticed that the lifeline setting is lost as well. I’m on OH 2.5.5 release, Win Server Core 2019 and Zulu JDK 8.44.0.11 (8u242), 64-bit.

ZWave2.log (15.6 KB)

From the log, there was no change -:

NODE 2: Configuration update ignored binding_cmdrepollperiod to 1500 (BigDecimal)

I guess this is an issue with PaperUI? I’m not really sure, but for sure it seems that the binding is not receiving the new value.