Danalock V3 Smartlock is not found in Openhab

I use 2 Smartlocks Danalock V3 with ZigBee.
In Phoscon and deConz they are found as lights but with the right manufacturer “Danalock” and as a “Smart Lock”.
I can control both of them in Phoscon, but OpenHab (deConz Binding) does not find the locks.
Does anyone use that Locks?
Is there perhaps a possibility to integrate the devices manually?

I have now tried to understand the REST-API and found the two Smartlocks there:

8: {
“etag”: “006d2b652564a68fae43512bd134dfde”,
“hascolor”: false,
“lastannounced”: “2020-10-26T13:55:50Z”,
“lastseen”: “2020-10-26T13:55Z”,
“manufacturername”: “Danalock”,
“modelid”: “V3-BTZB”,
“name”: “Kellertuer Verriegelung”,
“state”: {
“alert”: “none”,
“on”: true,
“reachable”: true
“swversion”: “15122017”,
“type”: “Door Lock”,
“uniqueid”: “00:0b:57:ff:fe:59:dc:ef-01”
9: {
“etag”: “45e7b38aa7bb4810f878bce1e7b45ce1”,
“hascolor”: false,
“lastannounced”: “2020-10-26T14:04:33Z”,
“lastseen”: “2020-10-26T14:04Z”,
“manufacturername”: “Danalock”,
“modelid”: “V3-BTZB”,
“name”: “Haustuer Verriegelung”,
“state”: {
“alert”: “none”,
“on”: false,
“reachable”: true
“swversion”: null,
“type”: “Door Lock”,
“uniqueid”: “00:0b:57:ff:fe:46:f1:4b-01”

But I do not understand how I can create this manually in OpenHab.
Or will that not work because “type”: “Door Lock” is not supported by the binding?

Hi Christian,

I use the zwave version of the Danalock since a few weeks and was able to discover it flawlessly.
How about using the zigbee binding if the danalock comes with zigbee (I don’t know the deConz

Is the Danalock running stable for you? For me with ZigBee it dos not?

I had the ZigBee binding for the last few years, but there are always problems after updates or with some devices. The two Danalock devices could no longer be controlled after a few days and had to be re-trained each time. Now I want to see whether Deconz-Phoscon is more stable for me. It also works very well, devices that never worked properly in the ZigBee binding are now running. Xiaomi things now have a battery status. Only the Danalock causes problems and I only want to use one radio system in the future, so I also replaced up to two devices with Zwave.

Okay, the thing is obviously not supported by the binding, I always find the following message in the logging:

2020-10-28 19:09:28.317 [DEBUG] [ding.deconz.internal.types.LightType] - Unknown light type ‘Door Lock’ found. This should be reported.
2020-10-28 19:09:28.318 [DEBUG] [ding.deconz.internal.types.LightType] - Unknown light type ‘Door Lock’ found. This should be reported.
2020-10-28 19:09:28.324 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Unknown type CLIPGenericStatus
2020-10-28 19:09:28.326 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Unknown type CLIPGenericStatus
2020-10-28 19:09:28.330 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Unknown type CLIPGenericStatus
2020-10-28 19:09:28.333 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Unknown type CLIPGenericStatus
2020-10-28 19:09:28.335 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Unknown type CLIPGenericStatus
2020-10-28 19:09:28.342 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Unknown type CLIPGenericStatus
2020-10-28 19:09:28.362 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Found light: V3-BTZB (Kellertuer Verriegelung), type UNKNOWN but no thing type defined for that type. This should be reported.
2020-10-28 19:09:28.362 [DEBUG] [rnal.discovery.ThingDiscoveryService] - Found light: V3-BTZB (Haustuer Verriegelung), type UNKNOWN but no thing type defined for that type. This should be reported.

There is a real chance that the support will be implemented in the near future.
Or is it possible to create this via the Ding & Item files without having to create everything via files?

I thought I found a dirty solution, the group would be found via the Hue binding and i can switch it, but unfortunately the locks do not react when the group is switched on / off. :cry:

1 Like

Is it conceivable that the type “Door Lock” will be integrated into the binding?

Thanks Jahn for the implementation, works wonderfully.
If Dresden Electronics could still provide the battery level in deCONZ, the Danalock V3 BTZB would definitely be recommended.

1 Like

Thanks for making this possible. I connected my Danalock V3 through conbee II/deconz binding in OH3. But after only one week the battery was drained, how is your battery holding up? Any special config choice I have to set up in deconz/ danalock to save battery?

That doesn’t happen with my two locks, I’ve been using them for 9 months and have 81% battery. Firmware is 0.16.0.

But I have the problem that both locks rarely work longer than 2 days via ZigBee. They then suddenly stop taking orders and I have to join them again. But they are online at this time and so i dont know about the Lock-Status.

The Danalock support does not think it is worth answering my repeated inquiries.
At first I thought it was because I could never control it via ZigBee, but now that it works in OH, it happens too. I cannot recommend the DANALOCK V3 BTZB.

I will give it a try with fresh batteries, and report back if I have the same issues.

Hi again. My lock have now been connected and working flawlesly 15 days and is no longer eating batteries :slight_smile:. Will report back if this changes

1 Like

I am now at 92% on the battery. I usually lock/ unlock once or twice a day. So there is hope for your lock as well :slight_smile:

Unfortunately for me it looks bad. Both locks now rarely work for more than a few hours and I can’t figure out why.
Today an update came for the locks, from 0.16.0 to 0.16.1, but that doesn’t change anything.

Which FW do you use in the locks and which deCONZ version?
And do you see the battery status?

Deconz version: 2.05.88
Built with Qt 5.11.3
Firmware version 0x26660700

Lock FW: 0.16.0

No I only see the lock posted as a light in phoscon without battery status. But in Openhab it is recognized as a Door Lock. I check battery status via my phone and blouetooth.

1 Like

Thanks, that’s interesting.
I use deCONZ 2.09.00 and the same FW as you.

As you see on image below, my lock is not directly talking to the USB stick. but to an range extender. Unknown is my Conbee II.


1 Like