Danfoss include LC 13

I want to include a Danfoss thermostat living connect Z LC-13 but the device would not instantiate. After inclusion Openhab shows unknown devices. I found the device in the device list on http://www.cd-jackson.com. What is going wrong?

I have noticed same issue. I have also updated latest OH2 snapshot but it doesn’t change the situation.
I didn’t have any inclusion problem with Vera+

Model is 014G0013 (SW 1.01).
I have already tried multiple times wake-up and include/exclude.

Habmin attributes says:
Type / ID
Firmware Version 0.0
Basic Class SLAVE
Generic Class NOT_KNOWN
Specific Class NOT_USED

@normen I got LC-13 Things work at last night on latest snapshot on OH2. I deleted Danfoss items on Habmin (I had couple LC-13 unknown state devices)and then I just included again on Habmin. They have then discovered right away. So don’t exclude them, just use delete and include again.

I didn’t get LC-13 work on earlier version on OH2 (same tricks as above) so maybe the latest snapshot did the tricks for me.

I still have E5 error on LC-13 so I need to figure out what to do next.

Hope these instruction help to you for LC-13 discovery.

My LC-13 is working now too. I have tried a several times and now everything is fine. But I don’t find a rule. I have included 3 devices and each including process was different. Try and error drives me to sucess. :slight_smile:

@normen, good to hear. Did you face the E5 problem on LC-13 device? If yes, did you found right way to fix it?

Next I try to disable polling time and change the wake up interval at 300 sec.

I’ve had E5 errors only if the LC-13 couldn’t find the controller for some time (e. g. Controller offline). When the controller got back online, the E5 error disappeared. And when it didn’t go away automatically, I just removed one battery for a second and then put it back in.

Until now, I got rid of E5 with this methods every time (however, I got E5 very rarely…).

I haven’t got the E5 error until now.

Did anyone figure out the root cause and a real way to solve it?? My hardware, incl. Aeon zwave stick gen5 controller including the 4 pcs. of the LC-13, work in indigo without any issue. I’ve been running the zwave stick with other sensor without issues in OH2 but the Danfoss LC-13 sdk. 4.55 sw.1.01 seem to be non-compliant to OH2!! Or at least the build I’m running(openHAB 2.1.0 - release build)

Any help is appreciated!!


Last night I figured out how to properly include Danfoss LC-13 thermostats with OpenHAB 2.2.

  1. Make sure you do have living connect Z thermostats. The one without the Z will not work properly. (see Danfoss living connect, new proprietary z-wave binding
  2. Put openHAB in incusion mode for Z-Wave binding.
  3. Press middle button of thermostat.
  4. Thermostat display will blink quickly for 10 to 25 seconds depending how good the connection is.
  5. Thermostat display will blink slowly for about 5 seconds.
  6. You should now see either “Node nn” or “Z-Wave Node nn” in the inbox.
  7. Add the device to openHAB
  8. Press middle button of thermostat again.
  9. Thermostat display will blink quickly for some seconds.
  10. Wait until blinking stops and repeat step 9 until no blinking will occur anymore. If blinking does not stop after some tries, the thermostat is too far away from the controller.
  11. The thing is now correctly included in the Z-Wave network.
  • The antenna symbol in the thermostat display should go away within a couple of seconds.
  • openHAB should now show something like “Z-Wave Node nn Danfoss LC-13 Thermostat”
  1. If you don’t see “LC-13 Thermostat” on the node, delete the node and search again. Now it should be included correctly in openHAB.

I hope that helps anyone struggling to include Danfoss LC-13 thermostats.

doesnt help for me :frowning: I have the “z” version but nothing is shown when I search for it …
Fibaro stuff worked fine!

Hi Jonas88

Did you try to move your Gateway physically close to the Thermostat when you put OpenHAB into discovery mode?
Furthermore update to the latest version of OpenHAB 2; currently I am using version 2.2.

I hope that helps.

2 h later i got it finally working.
there is a mistake in the manual for resetting those devices.
it’s written that you should hold the button for 5 secs and then put the batteries back in while holding the button.
thats false.
you have to take the batteries out, hold the button, put the batteries back in and continue holding the button for > 5 s for the device to reset …

I’ve updated the database to reflect this comment… It will flow into the documentation in a week or two.

hi chris,

it’s not your fault.
i looked at the official manual from danfoss and it’s the same!

.Hi jussi_railakari,

did you solve the E5 problem on LC-13 device? I have the same thermostat, the same problem an I cann’t how to fix it!

Thanks in advance.


Hi max3101

did you solve the E5 problem on LC-13 device? I have the same thermostat, the same problem an I cann’t how to fix it!

Thanks in advance.


Hello Lupe.

No, I switched to Home Assistant but that really didn’t solve my Zwave issues. I don’t think the E5 has much to do with OpenHab but more with the connection between valve and zwave controller. I bought a Vera Plus instead of the crappy z stick gen5 and its now working flawlessly here.
I don’t want to say anything bad about OpenHab; I’m just more into Home Assistant.

Good luck

Thank you very much max !