Danfoss LC-13 questions

I recently got a Danfoss LC-13 (Living Connect Z) installed, works like a charm out of the box. Just wondered a few things. Not purely OH related so I’ll put this in Off-Topic.

Firstly, the manual says the thermostat will open the valve to jog it around 11.00 every thursday. Sounds like a splendid idea, having in thought how often these valves get stuck. What I don’t understand though is: How wo the thermostat know what time or weekday it is? I haven’t found any settings for that. Is that something automatically sent from the controller?

Also there is a channel for “Time Offset” that “Provides the current time difference for the devices time”. I don’t understand. Can anyone explain to me what this channel does?

Hi again.
When I asked this it was from a purely academic interest. Now however it has rendered some importance. We were awakened in the middle of the night by the thermostat making sounds, presumably because it was doing it’s thursday job of exercising the valve. Drastically reduced the WAF of my new shiny thermostat, so I really need to set the date/time on it now. Strangely enough the manual doesn’t say a word about this.

You got any input on this, @chris?

Hi,
I have 3 of them. I didn’t know about this scheduled task by default. I know that to avoid limestone or other mechanical block periodically, also during summer time, the valve close and open itself. Anyway my valves are not so loud, I can hear them sometimes but only when I’m awake and it is quite in the room. Maybe you should watch at the commands class, but if are not supported in openHAB you cannot change the properties values.

Well, it’s not the valve, it’s the thermostat itself. It’s like one meter from the headend of our bed :wink:

Anyway, I checked and the device supports COMMAND_CLASS_CLOCK, I guess that’s the one. I don’t know how the openhab binding handles this?

edit: Found this thread about this. I’m a little bit confused here… Could it be that the “Clock Time Offset” channel is in reality the one I should be looking at to set the clock? So I could simply connect an Item to it and do a clock.sendCommand(ON) to set the clock? And how do I know if it works?

I believe that the clock should get set automatically. If I remember correctly, the time offset channel allows you to set a allowable offset and if the time of the device is outside this offset, it will be reset. So if you set the offset to 30 seconds, then when the binding reads the time, if it is more than 30 seconds off, it will be reset.

From memory, this is automatic and can’t be otherwise changed. If you wanted to see if it’s working ok, then I’d suggest to check the logs. Also makes sure that the channel configuration is enabled (ie it’s not set to 0) otherwise the clock won’t be updated.

1 Like

What exactly would I look for? The channel configuration is set to default (60) so I guess this should work, but I’m not certain…

I guess on startup, and when the channel is polled, you should see the time being polled and set. IF you have a channel configured, then you should see the time offset from actual time, so maybe this is the first step (if you’ve not already done this?).

Ok, did some debug log digging, found this:

2017-12-21 09:27:58.393 [DEBUG] [.commandclass.ZWaveClockCommandClass] - NODE 14: Received clock report: torsdag 09:29
2017-12-21 09:27:58.490 [DEBUG] [ve.internal.protocol.ZWaveController] - Notifying event listeners: ZWaveCommandClassValueEvent
2017-12-21 09:27:58.589 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 14: Got an event from Z-Wave network: ZWaveCommandClassValueEvent
2017-12-21 09:27:58.701 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 14: Got a value event from Z-Wave network, endpoint = 0, command class = COMMAND_CLASS_CLOCK, value = Thu Dec 21 09:29:58 CET 2017
2017-12-21 09:27:58.762 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 14: listening == false, frequentlyListening == false, awake == true
2017-12-21 09:27:58.793 [DEBUG] [ternal.converter.ZWaveClockConverter] - NODE 14: Clock was 119 seconds off. Time will be updated.

So it seems it works as it should. The clock in the thermostat seems to be utterly crap though, every two hours or so it’s a couple of minutes off and has to be set…

Hi!

How did you include them?
I don’t see them listed in the “supported device”-list
And even after factory-reset they won’t show up in my item search.
My fibaro items did so I am sure that my stick works.

Is it this one?

https://www.openhab.org/addons/bindings/zwave/thing.html?thingTypeUID=danfoss_lc13_00_000

yep.
I did find it finally in the web.
I initially looked for it in the things-description where I wasn’t able to find it.
still it does not show up during the inclusion process.
i have 3 thermostats and no one does even after I factory-reset them …

Hi Jonas, have you managed to pair them finally ?

Hi!

Yes. I don’t remember what the issue was.
I already sold them because i got rid of all my z-wave devices.

Could I ask in generally why? I see lot of people giving up on Z-Wave and I might want to buy Z-Wave devices in the future (now I only have WiFi switches LED controllers with WiFi), but I wonder why it is not-so welcomed by some users.
From this perspective it looks really promising, because it consumes less energy than WiFi (for battery powered devices) mains powered devices works as a repeater (with WiFi I have some problems in the corner of my house where I normally wouldn’t want to use WiFi) and lots of devices only have Z-Wave (for example thermostat valves).
Can you explain it? Which device you bought instead of the LC13 for thermostat valve?

Thanks!

Hi
I never had any issues at all. after 1 year the battery was still at 50 %.
But as we want to move soon i will buy a different heating concept. That’s the reason.
I will switch to KNX and abandon all wireless stuff (except wifi for phones of course).
The only thing that bothered me was the delay that is obvious when using battery components. i set it to 30 min and if you want it to react quicker more battery power is drained of course.