Danfoss LC-13 won't work


Here is my setup;

Raspberry Pi 3
OpenHabian (http://docs.openhab.org/installation/openhabian.html)
Aeotec Z-stick Gen5
Danfoss LC-13 thermostat

I’ve managed to get Openhab running at the Raspberry, and I’ve added the Z-wave stick through the Paper UI - after that I’ve discovered the thermostat and added it to Openhab. Now, I can’t control the thermostat - the temperature doesn’t change when i put in a set point. In the control panel it says that the thermostat is online?

Anybody who know what to do?

Thanks in advance!

I don’t see any wakeup information in the properties - has the device woken up recently? What is the wakeup period set to?

As this is a battery device, the device will only wake up periodically and only when it sends the wakeup can the controller update the temperature. You need to make sure this is set correctly or it won’t update so I would check this first.

I’ve tried to wake up the device by pushing the middle button as stated in the documentation.

Are you referring to the polling period? It’s set to 10 minutes;

No - polling won’t work if the device doesn’t wake up…

There should be a separate section called “Wakeup Configuration” (from memory)? This will have a “Wakeup period” configuration option.

The only setting I can find with wakeup is under the Z-wave stick;

Several hours has passed without any update.

No - that’s not the right place.

If there’s no wakeup configuration on the device, then I would question if the device is actually initialised at all. Is there an XML file for this device in the userdata/zwave folder? If so, can you post it here please.

This is how it looks like in Habmin for a fully initialized LC-13:

And this is the setting for the wakeup configuration:

Could you please help me how to look for the xml file?

When installed through openhabian, it’s var/lib/openhab2/zwave.

Hi I have to problem with is quit much like this. I have the same hardware and I find my danfoss thermostats, but they all show as unknoed devices. I see my xml file that Chris asked for.

Im very new to homeautomation, linux, rasberry pi and openhab, so there can be very simple mistakes I did in setting up my system.

Here is the properties from Habmin for the thermostat:

And the z-wave controller:

They probably need to be woken up while they are in direct range of the controller so that the controller can configure them. This is normal for battery devices - there will probably be a button you need to press to wake it, and once the device has configured it should then generate an XML.

This is for the controller.

Thanks for the quick answer.
I have placed the thermostats next to the my Aeotec Z-Stick Gen5 and press the wake up bottom several times, but with no success. The usb stick is conncted to my rasberry.
Should it be in parring move when I wake the thermostats?

I sucessfully added 2 of 3 by letting them stand net to the z-wave stick for 1 hour and then pressing the middel bottom once. I hope this can help other. The ubs stick was not in parring mode and now I see this in Habmin:

I think I get then on the z-wave network by having the z-wave controller on high power inclusion:

This should be the default I think…

Last night I figured out how to properly include Danfoss LC-13 thermostats with OpenHAB 2.2.

  1. Make sure you do have living connect Z thermostats. The one without the Z will not work properly. (see Danfoss living connect, new proprietary z-wave binding
  2. Put openHAB in incusion mode for Z-Wave binding.
  3. Press middle button of thermostat.
  4. Thermostat display will blink quickly for 10 to 25 seconds depending how good the connection is.
  5. Thermostat display will blink slowly for about 5 seconds.
  6. You should now see either “Node nn” or “Z-Wave Node nn” in the inbox.
  7. Add the device to openHAB
  8. Press middle button of thermostat again.
  9. Thermostat display will blink quickly for some seconds.
  10. Wait until blinking stops and repeat step 9 until no blinking will occur anymore. If blinking does not stop after some tries, the thermostat is too far away from the controller.
  11. The thing is now correctly included in the Z-Wave network.
  • The antenna symbol in the thermostat display should go away within a couple of seconds.
  • openHAB should now show something like “Z-Wave Node nn Danfoss LC-13 Thermostat”
  1. If you don’t see “LC-13 Thermostat” on the node, delete the node and search again. Now it should be included correctly in openHAB.

I hope that helps anyone struggling to include Danfoss LC-13 thermostats.

1 Like