Danfoss LC13 - Unknown Device

Tags: #<Tag:0x00007f616e63d108>

Hello,
I have an existing Z-Wave config in openHAB2 with a Fibaro Wall Plug, witch is working fine.
Today i added a Danfoss LC13 thermostat to the Z-Wave network. openHAB does recognized the node but in HABmin the Thing Type Label shows ‘Unknown Device’. So i do’nt see any device specific papameters…

2017-10-23 14:16:04.170 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0
2017-10-23 14:16:04.184 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing ‘zwave:device:7dc0f13d:node3’ to inbox.

However the Thing shows as being ONLINE

Also when i look in /var/log/openhab/zwave there are only two node .xml files; for the controller and for the Fibaro Wall Plug.

I run the stable version of openHAB2 and this morning i did an upgrade of the system and restarted it afterwards. Waited for 3 hours in the hope the z-wave recognition would have been completed…

I would greatly appreciate any suggestion how i can move on with this.
Kind regards, Bert

Wake it up, press the middle button.

Hi @sihui,
Thank you for taking a look in my issue. I did the middle button press on the LC13 wich gave the following log entry:

2017-10-23 16:47:03.182 [WARN ] [l.serialmessage.SendDataMessageClass] - NODE 3: Already processed another send data request for this callback Id, ignoring.

but when i refresh the HABmin pannel, it still gives the ‘Unknown Device’ by the Thing Type Label.

Press it a couple of more times until the *.xml file is created. Sometimes it helps to remove one of the batteries for a couple of seconds, put it back in and then press the middle button again.

Hi @sihui,
That did it, pressing several times (with an interval of a few minures) suddenly i saw the node3.xml apearing in the directory, and HABmin status changes also.
I did not yet removed the battery, but i was almost so far :slight_smile:

Thank you very much for your advice!

1 Like

I was searching how to get the temperature install in my sitemap, but i found it: have to use the setpoint element type… OK, now i can start with the scheduling of the temperature

@sihui, Just one question. Hopefully you have the Danfoss LC13 in use? If i change the temp in my UI and look at the LC13, i have to press a button in order to see the display. I then see that the LC13 is adjusting itselve with the send temperature. I think that has te do with the wake-up config for the battery saving mode.
Do you know if there is a posibility to wake up the LC13 when i send a new temperature to the device?
I beleave the wake up setting is now 1800 (30min). so i think in worst case the temp would be changed 30 min after i have ordered a different temp.
Regards, Bert

Not possible, you have to wait the time configured in the wakeup config.

My wakeup time is set to 300 seconds, battery life is about 9 month.

I have the same problem: today I added a Danfoss LC13 thermostat to the Z-Wave network. OpenHAB does recognized the node but in PaperUI the Thing Type Label shows ‘Unknown Device’. So I don’t see any device specific papameters. Only properties visible:

zwave_beaming true
zwave_class_basic BASIC_TYPE_ROUTING_SLAVE
zwave_class_generic GENERIC_TYPE_THERMOSTAT
zwave_class_specific SPECIFIC_TYPE_SETPOINT_THERMOSTAT
zwave_frequent false
zwave_listening false
zwave_neighbours
zwave_nodeid 10
zwave_routing true
zwave_secure false
zwave_version 0.0

The log says:

2019-01-29 19:54:26.225 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 10: Device discovery could not resolve to a thingType! Manufacturer data not known.
2019-01-29 19:54:26.227 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:028ccd21:node10' to inbox.
2019-01-29 19:54:54.201 [ERROR] [ing.zwave.handler.ZWaveSerialHandler] - Got I/O exception Input/output error in writeArray during sending. exiting thread.
2019-01-29 19:59:11.402 [ERROR] [ing.zwave.handler.ZWaveSerialHandler] - Got I/O exception Input/output error in writeArray during sending. exiting thread.

I tried pressing the middle button of the danfoss several times, but nothing happens.

The device did not send manufacturer data, please wake the node until it gets initialized.
If that does not help you may need to exclude and reinclude the device. Do a factory reset in between.

Actually I tried that several times. I have excluded en reincluded the divive maybe 7 times. I read on this forum about waking the node, and did that many times (both with USB stick in pairing mode and in normal mode. There seems to be no progress.
I use an “Aeotec USB stick Z-wave gen5” with OH installed on a Synolgy DS918+. Everything else is working fine.

In my experience, if after a few attempts to wake up the device doesn’t complete the initialisation I exclude it and then complete the include by using the controller directly. Which in my case is also a Aeotec USB stick. Also I have noticed that placing a battery device near to a mains device helps when including new devices.

Additionally you could leave things as they are for a full 24 hours, see if that helps in any way. Unless you need to get things working straight away. By leave 24 hours you should have completed a full network heal at least once and devices should have found their nearest neighbours. With Z-Wave being a mesh network the more routes a devices has available the quicker data travels.

1 Like