Danfoss Living Connect Radiator Thermostat not found by Z-wave stick

Tags: #<Tag:0x00007efed95ffaf8> #<Tag:0x00007efed95ff2d8>

Hi,
I have been trying to get the z-wave stick gen 5 to include the Danfoss Thermostat, but I cannot get them to pair. Has anyone experienced the same and managed to solve it?

There are (at least) two different versions of the thermostat available. One is only functional with the Danfoss own protocol. The other one works with zwave.

Do you have the zwave device? Can you post you product number? Should be 014G0…

Hi Jaydee73.
The one i have is a Z-Wave Living Connect 014G0013. So in theory there should be no problem…

Yep, this one is zwave.

I am using some of these devices for many months with Openhab. Also with Aeon stick gen 5. No problems at all.

Which OH version? Is the Aeon stick properly installed? Do you have other zwave devices which could be included? Just to make sure it’s no general problem.

Do you include the thermostat with the stick nearby or with the stick plugged into the gateway? What does the blinking circle of the stick tell you during inclusion?

The OH version I have is 1.8.3. I have a few devices already included via Z-Stick without a problem. The way I include devices is by removing the z-stick from USB and tapping the button which starts blinking blue slowly (I tried holding the button as well on few occasions). A the same time I follow the Danfoss manual - getting it to blink and show the antenna icon. At the end i get the antenna and the bell icons blinking on the thermostat display - showing there is no connection.

That’s exactly how I did it.

Do you have tried to do a factory reset of the thermostat and then try to include the device again? For inclusion mode, only a short tap of the middle button is necessary and the inclusion has to happen during 30 seconds.

Other than that, I am running out of suggestions. Sorry.

Unfortunately, the reset did not help. This leads me to believe that the thermostat might be faulty. The last thing I will try is installing the latest firmware on the z-stick. But not today.

Thanks for all your help!

Hi Tom

Did you manage to solve this issue? I am fighting with exactly the same problem right now …

Hi All, have you managed to resolve this problem ?

@Lukasz_S
This thread is 2 years old
Open a new open with all the info requested
Thanks

@Lukasz_S, I had to download an old Windows controller application for Z-stick to find out that the thermostat is still on the list of paired devices and remove it from there ( and I had to remove previously created zwave device files (XML AFAIR) from OH2). Only after that I could attempt to pair again.

Note: the Windows softwarw is from aeon labs, but they do not support it anymore and removed from their website. I had to use archive.org to get it (it was small enough to get archived).

Thanks for reply !
I tried Zensys Z wave controller (on Win) where I can see and pair my devices. However Danfoss still blinks network and alarm icons like it was’t paired.
Tried to unlink and pair it again but still the same result.
I use latest Aeon Gen5 stick.