Deconz offline: Phoscon-GW thing says "Error while connecting: Insufficient configured threads"

I run OpenHAB 3.1 in docker on a RaspberryPi. Deconz is also running in docker on the same Raspberry Pi.
Today I noticed that all things connected to deconz are offline in OpenHAB with status “Bridge_Offline”.
The Phoscon-GW thing is saying:

**COMMUNICATION_ERROR**

Error while connecting: Insufficient configured threads: required=11 < max=10 for QueuedThreadPool[OH-httpClient--deconz-00212E05B211]@1589858{STARTED,5<=5<=10,i=1,r=-1,q=0}[ReservedThreadExecutor@77d243{s=0/1,p=0}]

So does anybody know how to fix this?

Well, I disabled the Phoscon-GW thing via UI and then enabled it again.
Now the thing is back online. Let’s see if it stays online…

1 Like

I can confirm the same behaviour. The workaround also helps. It may be that there is too much going on during start-up.

The workaround works, but it is not sufficient on my opinion. I do not want to regularly check the UI and disable/enable the binding. I restart my Raspberry every night automatically and have sporadically the above mentioned issue.

Is there any way to increase the number of threads?

I run OH 3.1.0 inside Docker on a Raspberry Pi 2B.

1 Like

Have a look to this thread: Fix for Jetty error when running on host with many cores
According to the content it seems like that would help.

1 Like

First of all, thanks for the hint. I added

org.openhab.webclient:minThreadsShared = 10
org.openhab.webclient:maxThreadsShared = 50
org.openhab.webclient:minThreadsCustom = 10
org.openhab.webclient:maxThreadsCustom = 50

to the runtime.cfg in ./openhab/conf/services.

After one restart, the problem seemed to be away now. I first tried it with “maxThreadsCustom=30” but then the error again appeared with requiring more than 30 threads. I have no idea whether 50 is a reasonable value for my small RPi 2B. -(")-

Let’s see whether it happens again.

1 Like