deCONZ with Ikea light (LED2003G10)

This might be a new Ikea light which is not working perfectly yet with the deConz binding
In the PhosCon APP everything is working perfectly

What happens? When using the item (so changing the slider) with the available channel for color temperature this will ends up in a warning (end nothing happens (you can see some movement of the slider in the PhosCon APP (starts with running out of sight and than returning to original location):

2022-01-21 15:08:47.672 [WARN ] [.deconz.internal.netutils.WebSocketConnection] - Websocket$1642609467703-7 encountered an error while processing the message {“e”:“changed”,“id”:“4”,“r”:“lights”,“state”:{“alert”:null,“bri”:127,“colormode”:“ct”,“ct”:454,“on”:true,“reachable”:true},“t”:“event”,“uniqueid”:“2c:11:65:ff:fe:b5:79:1b-01”}: Value must be between 0 and 100

Ikea details (bought as a set with remote control) for €14.99

  • 805.134.16 50050NLD
  • E27 - 9,5W 1055 lm (LED2003G10)
  • Remote control: Styrbar

Thing (type deCONZ)

  • fwversion 0x26660700
  • zigbeechannel 11
  • apiversion 1.16.0
  • swversion 2.13.4

In Openhab this lamb is recognised with the following characteristics:

  • ModelID: TRADFRIbulbE27WSglobeopal1055lm
  • ctmin 1
  • ctmax 65279
  • firmwareVersion 1.0.012

To be honest this is one of my first experience with Zigbee; starting last Wednesday with ConBee II and some Philips lights and Yesterday this Ikea light and remote but thanks to comments found allover I was able to set everything up. Off course not directly finding the correct way to:

  • install the PhosCon APP (openhabian-config optie 29, behind 20, beautiful)
  • Pair an Ikea light (power 6x power off/on)
  • Pair the Ikea remote; by pressing the button on the back 4 times within 5 seconds and wait. BTW worked perfectly from a 4 meters distance of the ConBee II But the batteries were new and fresh)

My system details are:

  • Installed = OpenHABian
  • Release Build = 3.2.0 release build
  • Release = Raspbian GNU/Linux 10 (buster)
  • Kernel = Linux 5.10.63-v7l+
  • Platform = Raspberry Pi 4 Model B Rev 1.1

Can you show the thing configuration (tab “Code” in the UI)? What item is linked to which channel?

The error occurs when you use the color temperature slider in Phoscon or in the openHAB UI?

@J-N-K hope I give the desired answers to your questions:

Can you show the thing configuration (tab “Code” in the UI)?

UID: deconz:colortemperaturelight:zigbee:2c1165fffeb5791b01
label: Red Lamp (IKEA of Sweden)
thingTypeUID: deconz:colortemperaturelight
id: “4”
bridgeUID: deconz:deconz:zigbee

What item is linked to which channel?

To be honest I defined this item manually in an item file as “Dimmer”, which appears to be incorrect.
With a new item creation the item is a number.
fyi The range (changing in Phoscon and reading the value in Openhab) is 2200 - 4000 (Kelvin)

So problem solved, will solve changing this value in Openhab later this day.
Thanks for put me on the right track of own problem.

The problem with ctmin/ctmax is that openHAB relies on the values reported by the deconz API. It could be that Phoscon has an additional internal database for that.

Do you see a ctmin/ctmax value in the log (set level to TRACE) for this device when you disable/enable it?

Problem already solved; I should have defined the color-item as a number and not as a dimmer, the value itself of this channel (deconz:colortemperaturelight:zigbee:2c1165fffeb5791b01:color_temperature) can vary between 2202 and 4000.

So it is not a real color temperature item but more an ambiance / kelvin value.
Interaction with above change works perfectly and selection inside Openhab already solved:

To keep girlfriend happy I defined a simple sitemap for my lights (now working on a mix of 433, wifi and zigbee). Either one of the three lines below can be used for this example:

Slider  item=Zigbee_Red_C minValue=2202 maxValue=4000 visibility=[Zigbee_Red!=0]
Setpoint  item=Zigbee_Red_C visibility=[Zigbee_Red!=0] minValue=2202 maxValue=4000 step=300
Selection item=Zigbee_Red_C  visibility=[Zigbee_Red!=0] mappings=[2202=Warm, 2702=Normaal, 4000=Koud]

Examples hopefully give other NOOBS like me some guidence :laughing:
But in the end let’s face it; changing the warmth of this light after the inital setting will not be done often.

1 Like