Default Icons missing after update to #1506

Anyone else having issues after updatign from 1502 to 1506…in Classic UI and BasicIUI all default icons are missing…my personal ones are available…the rest I only see placeholders…
Just me? What can i do to make them come back? Thanks a lot Norbert

1 Like

It’s been reported elsewhere. The current snapshot is broken because of the moving and merging of ESH into OH. So all the add-ons that used to be hosted on ESH are not seen. Watch the The Road Ahead - Reintegrating ESH for updates.

But it is getting better again, at least the UIs install again now :slight_smile:
The icon problem should be fixed with https://github.com/openhab/openhab-distro/pull/854 soon.
As a temporary workaround, you can do a

feature:install openhab-iconset-classic

in the console.

5 Likes

@Kai
I attempted this on my build #1506 and got the following message:

openhab> feature:install openhab-iconset-classic
Error executing command: Error restarting bundles:
Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.rest.sse.

EDIT: Even though i received the message above, I can confirm that the icons are now appearing correctly.

One other thing i’ve noticed since upgrading to #1506 is that everytime i send a command from the sitemap i get the message at the bottom of the screen “Offline: waiting for connection to become available” with the following in the error logs:

2019-01-23 09:09:08.186 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent.

Build #1507 fixed both the error received when i ran “feature:install openhab-iconset-classic” and i no longer get the message “ Offline: waiting for connection to become available ” anymore :+1::+1:

sorry to come up with the topic again.
After my upgrade to 2.5 (from 2.4 rpi3) the classic icons are gone.
If i download them one by one as svg an put them into the /icons/classic folder, they work.
I already tried feature:install openhab-iconset-classic but nothing happend or changed.
I only get: -bash;feature:install: command not found

Would be nice if you can give me a hint
BR
Daniel

That command is to be run from inside the Karaf Console. https://www.openhab.org/docs/administration/console.html

Thank you. Now it works.
Funny thing is that the item based status of the garage door icon works on the tablet, but not in my browser on my pc (open works, closed doesn`t) but that is not an issue for me.
BR an thank you

A few months ago I had updated from 2.4 to 2.5 on my Raspberry Pi 3 (Openhabian distro) and my icons in the Eclipse SmartHome Classic iconset disappeared. After searching for a while I found Kai’s solution and solved the issue:

Yesterday (after a few weeks of not applying updates) I decided to update the 17 pending items in the queue, and after the update finished icons were gone once again.
I bookmarked the fix in case it happens again in the future.

It is still broken in 2.5.7

Yes, still broken.

what is the status here? I’m not able to get my own dynamic icons in icons/classic to run. In BasicUI nor in ClassicUI i find the setting to change from png to svg or Bitmap to Vector. By the way i need png

Are you having trouble with default icons too?

So far as I know, the option to switch png/svg for each UI vanished about 6 months ago. I think no-one has logged a github issue.

Have you ever had custom icons working before? There are some easily missed things you need to get correct.

I have a clean installation of 2.5.8 The dynamic Icons (default) are working but custom icons with PNG not

Okay, so we don’t know if you ever had it working before.
There are still some easily missed things that you need to get correct, but can’t say whether you have got it right or nor.

What are your image filenames- the whole set?
There must be one and only one hyphen in the filename.
You must supply a default image file with no hyphen.
Numerics 0-100 only allowed.
All lowercase.

What is the raw state of the Item?
Label [transforms] are ignored here.

thanks for the great support. I think the issue was that i didn’t only use numbers after the hyphen. I think this should be added to the documentation.

I’m not sure what you mean, without examples.
Dynamic icons are not limited to numbers, but if you do use numerics they’ll only work as expected in the 0-100 range.
myicon-off.png , myicon-fred.png, myicon-99.png are valid. (when used with appropriate Item states)
myicon.png must always exist, or they will not work.

myicon-OFF.png , myicon-fred-mary.png, myicon-299.png are not going to work properly.