Default page and Paper UI won't load

  • Platform information:
    I’m running openHAB 2.4 off of openhabian on Ubuntu 18.04 on an old Dell Optiplex (pentium class CPU).

I’m having some odd issues after attempting to install openHAB Cloud via the Paper UI addons. I never got a UUID or Secret generated, so I checked over all my configurations and realized I’d installed Zulu JDK 10 instead of 8. So I shut down openHAB, uninstalled Java, reinstalled Zulu JDK 8 and rebooted. I was able to connect to the start page and Paper UI initially and didn’t see any errors. I reinstalled openHAB Cloud and finally got the UUID and Secret and was able to connect to

Fast forward a few hours later, still says I’m online, I still have access to Basic UI and HabPanel, but the start page and Paper UI are non-responsive. I get a 404: Problem accessing paperui/start.html. Reason: Not Found. I’ve already tried updating via openhabian, I think I may just have to reinstall fresh. Anyone have a list of steps to follow for a clean install or do I have to wipe the machine and start over from scratch?

Update: I did find some related logs after rebooting and trying again. PaperUI worked briefly and then died again.
``2019-08-13 22:08:28.177 [INFO ] [ebuilder.internal.HomeBuilderServlet] - Stopped Home Builder
2019-08-13 22:08:28.191 [INFO ] [arthome.ui.paper.internal.PaperUIApp] - Stopped Paper UI```
and then there’s a whole mess of logs related to uninitializing and removing all my items, but nothing to indicate why it’s stopping. What the heck, dude.

Try clearing the OH caches. Different Java versions could easily have written different stuff in them and be confusing things:

Won’t hurt, even if it’s not the answer, and it might unstick you.