Delete old MQTT brokers

Well I finally got the MQTT binding to work in my openhab 2 instance.
But since i have messed around with a lot of different solutions, and had some troubles regarding old owner privileges, I installed and removed the MQTT binding a lot of times.

Now it’s working just fine, but in the logs I can see that all of the old different mqtt clients I tried using is still in there trying to connect to my mqtt broker.

I’ve tried restarting openhab, deleting the mqtt.cfg and restarting openhab again, nothing seems to work. I also tried upgrading from 2.1.0 to 2.2.0.

Any thoughts about how to reset something to get rid of the old connections??

This is output from my log

09:44:46.309 [INFO ] [rt.mqtt.internal.MqttBrokerConnection] - Starting connection helper to periodically try restore connection to broker 'broker’
09:44:56.319 [INFO ] [rt.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection 'broker’
09:44:56.327 [ERROR] [rt.mqtt.internal.MqttBrokerConnection] - MQTT connection to broker was lost
org.eclipse.paho.client.mqttv3.MqttException: Connection lost
at []
at [?:?]
Caused by:
at ~[?:?]
at org.eclipse.paho.client.mqttv3.internal.wire.MqttInputStream.readMqttWireMessage( ~[?:?]
at ~[?:?]
… 1 more
09:44:56.329 [ERROR] [rt.mqtt.internal.MqttBrokerConnection] - MQTT connection to ‘mosquitto’ was lost: Connection lost : ReasonCode 32109 : Cause : null

I see that this topic: Mqtt: get rid of old config actually has the same problem as me. Anyway to get in somewhere and delete that old config files ?

Try This
First result will be