Deleted rule stays active

  • Platform information:
    • Hardware: Raspberry Pi 4 Model B Rev 1.2 / 4GB
    • OS: Linux webhabian 5.10.17-v7l+ #1403
    • Java Runtime Environment: OpenJDK Runtime Environment Zulu11.45+27-CA (build 11.0.10+9-LTS)
    • openHAB version: 3.0.1 - Release Build

I created a rule using the BasicUI. (a Zwave socket switches by a Zwave motion detector)
I deleted that rule by the UI.
For reason unknown the rule keeps working.

I looked in /var/lib/openhab/jsondb and the rules file (active and non-active) do no longer contain the rule.
There is nothing in /config/rules

I tried stopping the daemon and clearing the cache (openhab-cli clean cache) and restarted.
I tried rebooting the system, all to no avail.

Any suggestion on where my rule is sticking?

All I can offer is if the rule does not exist in the automation.json file and you’ve restarted openHAB, then what ever you are seeing is not coming from the rule you deleted but from somewhere else. Once it’s gone from the JSONDB file it’s gone.

The only exception to that is if the SD card this is running on is wearing out in which case when you delete the rule it doesn’t really get deleted. But that is highly unlikely.

What makes you think the rule is still around?

Silly me.
I’ve accidently added the zwave socket to the Zwave motion group…
Thus, each motion alert activated my light.
Because I just deleted this rule about the same time I fiddled with my settings I didn’t quite make the connection…
Thanks for the reply!