Designer windows 64x

I just downloaded the designer build and keep getting a jvm error - due I think to the fact that it’s a 64 bit OS. Has the eclipse build not been updated to 64x yet and/or is there a workaround for this?

There is an easy solution, just install a 32bit JRE and you are ready to use the designer with your 64bit OS.


Hello, I have the same problem.

If I execute openHAB-Designer.exe I get the following error:

“Java was started but returned exit code=13”
It is using “C:\ProgramData\Oracle\java\javapath\javaw.exe” that it is pointing to a 64bit java installation.

After that, I installed a 32bit java. Now, I need to config the openHAB-Designer.ini to indicate the 32bit java due to I need to keep the default 64bit java.
If I put “-vm C:\Program Files (x86)\Java\jdk1.8.0_66\bin\javaw.exe” before -vmargs it gives me the same error and if I put the -vm command after the -vmargs it gives me an exit code=1.

How could I solve this problem? Using -vm alwayis worked for me in other eclipse installations.

Thank you.

Did you put the path in “”

Yes, I tried with -vm “C:\Program Files (x86)\Java\jdk1.8.0_66\bin\javaw.exe”

It is not a big issue, I’m using a script that solves the problem with my path configuration.

I add the script code for someone with the same problem:
set path=C:\Program Files (x86)\Java\jdk1.8.0_66\bin;%path%
start “” “.\openHAB-Designer.exe”


I am having this same problem on Linux (both 32-bit and 64-bit).

Hello Nandez3,
Where you add the script code ??
set path=C:\Program Files (x86)\Java\jdk1.8.0_66\bin;%path%
start “” “.\openHAB-Designer.exe”


I created a text file named launcher.bat in the root directory of the designer.
Copy the commands in that file and start the designer using launcher.bat instead of openHAB-Designer.exe.

That is working in my instalation.


Thanks for the answer !