Device not present in database: ZW095-C


I’m using openhab 1.8.3 with:

  • org.openhab.binding.zwave-1.9.0-SNAPSHOT.jar (
  • (

My device seems correctly detected as Node 4 but I cannot configure it. In GUI under Configuration > Bindings (ZWAVE - Z-Wave Binding) > Devices > “Node 4”, the nodes “Configuration Parameters” and “Association Groups” are empty, even after a refresh.

Device name is: Home Energy Meter - Gen 5
Model: ZW095-C (230V, 50Hz, EU/AU 1 phase). Model with 1 clamp.

The version existing in database is the version ZW095-A which is US model (120V, 60Hz, USA 2 phases).
I tried to upload my xml file as suggested in the Database Guide, but upload seems now disabled.

I attached my node4.xml and zwave.log (renamed to zwave.log.xml to be accepted as an attached file).

I think version 1 phase (1 clamp) and 3 phases 4 wires (3 clamps) are same model, only the number of clamps differs.

Documentation for the 3 phase version:

Is it possible to add it in database?

In the zwave.log, there’s a stacktrace:

Caused by: java.lang.IllegalStateException: NODE 4: node wants to use security but key is not set
	at org.openhab.binding.zwave.internal.protocol.commandclass.ZWaveSecurityCommandClass.<init>( ~[bundlefile:na]

Not sure it is important as data seemed to be received…

node4.xml (3.3 KB)

zwave.log.xml (185.9 KB)

It’s not disabled, but as described in the information, you need to register, and then email so that you can get access…

I’ve added the ids to the database - it will need a PR to add it to OH1 which I’ll do in the next day or so (hopefully tomorrow).

Yes I registered, received an activation email, then I could login. But “Add” button doesn’t show in the device list page. I just tested again with Chrome and Firefox and still not Add button… that’s the reason I posted here :slight_smile:

Thanks for adding it in the database.


As I said above - you need to email me so that I can actually give you access… If you let me know your user name I can update your access…