Diferrent IP item Status dosen't show

I’m having an issue with my openHab setup and I would appreciated your help. :slight_smile:

My openhab instance is installed in a different IP address than my items, and it doesn’t show me the status of the items in the dashboards.

My openhab is on ip for ex. and my things on 172.15.0.xxx, that’s because I would like to access things that are in different locations but using only one openhab instance.

If I open openHAB on the same subnet than the items, the staus works fine and i can switch on and off them. If I go to a different subnet they stay grey and can’t switch them on/off.

Do you know why this is happening? As anyone had this problem before? I tried to find help in the forum, but did not find anything close to this issue.

Thanks in advance :smiley:

It may help if you could let us more details about what kind of things you talk as the detection for these things may be different kind of methods like broadcasts …

Sure :slight_smile: the things are Shelly 4PM Pro 2º generation.

They even show as online in openHAB but in a different subnet cant seem to switch them on or off…

imagen in a different subnet:

Thanks for the help!

image when I open openhab in the same subnet as the things:

Devices on two different subnets can’t communicate unless you set up your networks to allow it. You probably won’t find much discussion about it in the community, because it’s a network issue that doesn’t have anything to do with your OH server. I suggest Googling “can devices on different networks communicate”.

Yes, that was my first guess, but I tried home assistant and it works fine in different subnets. That’s what I thing is strange.

I’ve no idea about HA, but it’s more surprising to me that it worked. Google search shows lots of people tallking about it.

In fact, you’ll have to setup a route to the other subnet., either via firewall rule (i.e. forward the traffic to the subnet) or via vpn (so that both subnets are virtually the same subnet)
But Russ is completely correct, that is out of scope of openHAB.

It sounds like you’re having trouble accessing the status of your items in openHAB when they are on a different IP address than your openHAB instance. The items work fine and can be switched on/off when accessed from the same subnet as the items, but when accessed from a different subnet, the items stay greyed out and cannot be switched on/off. One possibility could be a network configuration issue or firewall blocking access to the items from the openHAB instance.

@Cassy0110, are you just posting ChatGPT responses? If so, please stop.

Thank you all for the help, I’m not an expert in networking but we have several buildings connected with routers and switchs. I can get to the http web page of the Shelly items in any subnet, just can’t change their staus on openhab outside the same subnet as the items.

With HA I can do it with no problems, that’s why I thought it could be something with openHab…