Dimension change on Paper UI are not recognized correctly

  • Platform information:
    • Hardware: openHABian
    • openHAB version: 2.4
  • Issue of the topic: Dimensions were not displayed correct

All, I’m new to openHAB and installed the system some days ago and in process to setup the platform. Now I face an issue with dimensions. The binding with my Homatic Wall Thermostat with switching output gives back two values, set temp and actual temp. Set temp was recognized with “number:temperature” and actual with “number:dimensionless”. This leads that the actual temp is displayed incorrect without °C, just as a string. When I change the dimension on the channel portal at Paper UI to temperature, the change is not translated correctly and the display shows “-NaN”.

I wonder where do I need to change the config to apply the dimension the right way ?

Your feedback would be highly appreciated.

Thanks in advance

I think you’d need to look at the channels coming from the binding, what are they?

Did you set your Measurement System?

Hi sihui, thanks for your reply. Where do I find this option in Paper UI ? I can’t find it in system …

homematic:HmIP-BWTH:1#SET_POINT_TEMPERATURE / Number:Temperature
homematic:HmIP-BWTH:1#ACTUAL_TEMPERATURE / Number:Dimensionless

That looks like an issue with the binding. I think you’d have to work around it by using it as Dimensionless Item and just displaying °C yourself in the Item’s label format [] part.

I fear it might break if you get a negative temperature or over 100, but I don’t suppose that’s likely here.

PaperUI -> Configuration -> System -> Regional Settings -> Show more …

thanks, got that fixed but the problem stays the same. I tried to change the type in the DB but after a reboot it got overwritten from the binding I guess. Is there another location where I can change decimals or units e.g. C to F ?

Did you try with a plain number itemtype (without temperature or dimensionless)?

Hi bandimuc,
Did you find a way to get decimals from the HMIP-BWTH to OpenHab? I also only get integers or -Nan.

Hi fdeussen,

I added following text to the format field in HABPanel and it worked -> %.1f °C
Changing stuff in Paper UI didn’t help at all.

You also should check Paper UI > Configuration > System > Regional Settings > Show more > Measurement System > Metric or Imperial (US)

Hope this helps
B.

Thanks!

So this seems to be a Paper UI issue only that no decimals / only integer values from HMIP-BWTH Temperature connected to Openhab via RaspberryMatic were shown.
I started logging values with influxdb and there are also decimals showing up for temperature :slight_smile:

The problem lies here, the channel trying to fit a temperature into a Dimensionless (0-100%) type number…